HDU 5115 Dire Wolf 区间DP+记忆化搜索

Dire Wolf
Time Limit: 5000/5000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 749 Accepted Submission(s): 438


Problem Description
Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by bi. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks bi they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.


Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).

The second line contains N integers ai (0 ≤ ai ≤ 100000), denoting the basic attack of each dire wolf.

The third line contains N integers bi (0 ≤ bi ≤ 50000), denoting the extra attack each dire wolf can provide.


Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.


Sample Input
2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1


Sample Output
Case #1: 17
Case #2: 74

Hint
In the first sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.



Source

2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

题意:1:T cases ; 2:给出N 头狼的攻击伤害 ; 3:给出每头狼对两边的狼的伤害加成 。

思路:设dp[ i ] [ j ] 意为: 第 i 头狼到 第 j  头狼的全部KO的最少伤害。

从 [ i , j ] 枚举 狼 k  。 即该区间最后K掉的狼 , 则 dp[ i ] [ j  ] = dp [ i ] [ k - 1]  + dp [ k + 1 ] [ j ] +  basic [ k ]  + extra[ i - 1 ] + extra[ j + 1 ]  ;

初始化不难得出为 dp[ i ] [ i ]   = basic[ i ]  + extra[ i -1 ] + extra[ i + 1 ] ;

   代码 : 记忆化搜索+区间DP 

#include <iostream>
#include <cstdio>
#include <cstring>
#define min(a,b) (a<b?a:b)
#define FOR(a,i,b) for( i = a ; i <= b ; ++i )
#define CLR(arr,x) memset(arr,x,sizeof(arr))
using namespace std;
const int maxn = 300 ;
const int inf = 1<<30 ;
int a[maxn] , b[maxn] ;
int temp[maxn][maxn] ;
int n ;
void init() {
    CLR(a,0) ;
    CLR(b,0) ;
    CLR(temp,0) ;
}
int dp(int l , int r ) {
    if( l > r ) return 0 ;
    if( l == r) return (a[l]+b[l-1]+b[l+1]) ;
    int& ans = temp[l][r] ;
    if( ans > 0 ) return ans ;
    ans = inf ;
    for( int i = l ; i <= r ; ++i ) {
        ans = min(ans, dp(l,i-1)+dp(i+1,r)+a[i]+b[l-1]+b[r+1]) ;
    }
    return ans ;
}
void scan(){
    scanf("%d",&n) ;
    int i ;
    FOR(1,i,n){
        scanf("%d",&a[i]) ;
    }
    FOR(1,i,n){
        scanf("%d",&b[i]) ;
    }
    dp(1,n) ;
}
int main() {
    int t ;
    int ncase = 1;
    scanf("%d",&t);
    while(t--) {
        init() ;
        scan() ;
        printf("Case #%d: %d\n",ncase++,temp[1][n]) ;
    }
    return 0 ;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值