F - John HDU - 1907(尼姆博弈)

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.


Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

Sample Input
2
3
3 5 1
1
1
Sample Output
John
Brother





题目的意思就是说谁拿到最后一颗谁就是输

嗯这个要考虑两种情况就是

1 特殊情况  如果全部都是1的话   是偶数的话那么就是先手赢不然就是后者赢

2 就是尼姆博弈 嗯面对奇异局势的话 哪一方都没有办法

代码如下

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
	int t;
    cin>>t;
    while(t--)
    {
    	int n;
    	cin>>n;
    	int flag=0;
    	int temp=0,gg;//0和任何东西yi或都是  任何东西 
        for(int i=1;i<=n;i++)
        {
        	cin>>gg;
        	temp=temp^gg; 
        	if(gg>1)
        	flag=1;
        }
		if(flag)
		{
			//面对奇异局势那么哪一方都没有办法 
			if(temp==0)
				puts("Brother");
			else 
				puts("John");
			
			
		}//一下是特殊情况需要具体考虑下
		//如果都是1 并且是偶数 那么是先手赢 不然就是后手赢 
		else 
		{
			if(n%2==1)
				puts("Brother");
			else 
				puts("John");
		}		
    }
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值