John(HDU 1907) —— 尼姆博弈

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2962    Accepted Submission(s): 1664


Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.


Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747


Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.


Sample Input
  
  
2 3 3 5 1 1 1

Sample Output
  
  
John Brother
题意:有n种石块,每种石块有a[i]个。两个人,John先拿,每次可拿任意个石块,但必须是同一种,谁拿到最后的石块输。
 
思路:列出各种情况,1堆、2堆、3堆...一开始觉得与奇偶有关系,但后来发现不是,于是想到了异或关系(这些情况很杂,不是奇偶,特别的规律也很难搞,所以根据经验只能想到异或,其它的东西我也不知道),然后发现异或可以解决我自己举出的案例,故一试,成功。
#include<stdio.h>
int main()
{
    int T, n, i, a[50];

    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        int x = 0, num = 0, flag = 0;
        for(i=1; i<=n; i++)
        {
            scanf("%d", a+i);
            x ^= a[i];
            if(a[i] == 1) num++;
        }
        if(n & 1 && (x == 0 || num == n)) flag = 1;
        if(n % 2 == 0 && x == 0 && num != n) flag = 1;
        printf(flag ? "Brother\n" : "John\n");
    }
    return 0;
}

代码中把n%2==0换成n&1==0结果不一样,不知为何,都是判断奇偶的啊。。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值