A - Six Degrees of Cowvin Bacon POJ - 2139 最短路Floyd

实在是坑在输出这里wa了好几发
注意是输出是整数整数整数的形式我至今不明为何

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.
Output
* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.
Sample Input
4 2
3 1 2 3
2 3 4
Sample Output
100
Hint
[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
int n,m;
int cow[305][305];
int digit[10005];
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			cow[i][j]=inf;
			
			cow[i][i]=0;
		}//奶牛们的初始化 
		for(int k=1;k<=m;k++)
		{
			int t;
			scanf("%d",&t);
			for(int i=1;i<=t;i++)
				scanf("%d",&digit[i]);
			for(int i=1;i<=t;i++)
			{
				for(int j=1;j<=t;j++)
				{
					if(digit[i]==digit[j]||i==j)
					continue;
					else cow[digit[i]][digit[j]]=1;
				}
			} 
			for(int k=1;k<=n;k++)
			{
				for(int i=1;i<=n;i++)
				{
					for(int j=1;j<=n;j++)
					{
						if(cow[i][k]+cow[k][j]<cow[i][j])
						cow[i][j]=cow[i][k]+cow[k][j];
					} 
				}
			}

			int maxn=inf;
			int u;
			for(int i=1;i<=n;i++)
			{
				int ans=0;
				for(int j=1;j<=n;j++)
				{
					if(cow[i][j]==inf||cow[i][j]==0)continue;
					else 
					{
						ans+=cow[i][j];
					}
				}
			maxn=min(maxn,ans);
			}
			int  gg=100*maxn/(n-1);
			printf("%d\n",gg);
	}
	return 0;
} 

      
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值