Bookshelf 2 POJ - 3628(01背包||DFS)

Bookshelf 2

POJ - 3628


Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ BS, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input
5 16
3
1
3
5
6
Sample Output
1

代码:搜索

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int digit[25];
int book[25];
int gg[25];
typedef long long ll;
int n,b;
int inf=0x3f3f3f3f;
void DFS(int cnt,int sum)
{
	if(sum+gg[n]-gg[cnt-1]<b)return;
	if(sum>=b){
		inf=min(inf,sum);
		return;
	}
	DFS(cnt+1,sum);
	DFS(cnt+1,sum+digit[cnt]);
	return;
}
int main()
{   
	scanf("%d%d",&n,&b);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&digit[i]);
		gg[i]=gg[i-1]+digit[i];
	}	
	DFS(1,0);
	printf("%d\n",inf-b);
    return 0;
}

代码:DP

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int digit[25];
typedef long long ll;
int n,b;
int sum=0;
int inf=0x3f3f3f3f;
int dp[1000000*20+5];
int main()
{   
	scanf("%d%d",&n,&b);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&digit[i]);
		sum=sum+digit[i];
	}	
	for(int i=1;i<=n;i++){
		for(int j=sum;j>=digit[i];j--){
			dp[j]=max(dp[j],dp[j-digit[i]]+digit[i]); 
		}
	}
	for(int i=1;i<=sum;i++)
	{
		if(dp[i]>=b){
			cout<<dp[i]-b<<endl;
			break;
		}
	}
		
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值