HDU 5512(博弈论)

n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n. However, only two of them (labelled a and b, where 1abn) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i{a,b} and 1in) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=jk
. Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
Input The first line contains an integer t (1t500) which is the number of test cases.
For each test case, the first line provides the positive integer n (2n20000) and two different integers a and b. Output For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time. Sample Input
16
2 1 2
3 1 3
67 1 2
100 1 2
8 6 8
9 6 8
10 6 8
11 6 8
12 6 8
13 6 8
14 6 8
15 6 8
16 6 8
1314 6 8
1994 1 13
1994 7 12
Sample Output
Case #1: Iaka
Case #2: Yuwgna
Case #3: Yuwgna
Case #4: Iaka
Case #5: Iaka
Case #6: Iaka
Case #7: Yuwgna
Case #8: Yuwgna
Case #9: Iaka
Case #10: Iaka
Case #11: Yuwgna
Case #12: Yuwgna
Case #13: Iaka
Case #14: Yuwgna
Case #15: Iaka
Case #16: Iaka

 转载来自:https://blog.csdn.net/mystery_guest/article/details/52072810

emmm昨天做这题的时候没有想到gcd被题目的样例给误导了 一直想的是他们的差值的多少却没有想到其他的

今天看了下题解是扩展欧几里得

意思就是如果ab互为质数的话那么一定可以得到一个1 那么一定也可以得到每个东西或者a==1||b==1

如果他们不互相为质数的话 那么他们可以取到他们的最大公约数里面所有有关公约数的倍数

就是这个样子那么就是n的个数除以他们的最大公约数就是里面可能的个数  之后减不减2都无所谓

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int t,n,a,b;cin>>t;
	for(int i=1;i<=t;i++)
	{
		scanf("%d%d%d",&n,&a,&b);
		int temp = __gcd(a,b);
	    printf("Case #%d: ",i);  
		if(a==1||b==1||temp==1)//如果ab互质 
		{
			if(n%2==1)printf("Yuwgna\n");
			else printf("Iaka\n");	
		}else //如果ab不互质  那么只要是gcd都能修建 
		{
			int gg=n/temp-2;
			if(gg%2==1)printf("Yuwgna\n");
			else printf("Iaka\n");	
		} 	
	} 
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值