HDU 5512Pagodas扩欧+容斥原理



Pagodas

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 677    Accepted Submission(s): 510


Problem Description
n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n . However, only two of them (labelled a and b , where 1abn ) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i{a,b} and 1in) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=jk . Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
 

Input
The first line contains an integer t (1t500) which is the number of test cases.
For each test case, the first line provides the positive integer n (2n20000) and two different integers a and b .
 

Output
For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.
 

Sample Input
  
  
16 2 1 2 3 1 3 67 1 2 100 1 2 8 6 8 9 6 8 10 6 8 11 6 8 12 6 8 13 6 8 14 6 8 15 6 8 16 6 8 1314 6 8 1994 1 13 1994 7 12
 

Sample Output
  
  
Case #1: Iaka Case #2: Yuwgna Case #3: Yuwgna Case #4: Iaka Case #5: Iaka Case #6: Iaka Case #7: Yuwgna Case #8: Yuwgna Case #9: Iaka Case #10: Iaka Case #11: Yuwgna Case #12: Yuwgna Case #13: Iaka Case #14: Yuwgna Case #15: Iaka Case #16: Iaka
题意:给你t组数据,一个n(表示有n座塔可以修)和两个数j和k(表示已经修的两座塔),每次只能修的塔i=j+k或者i=j-k,谁不能修谁就输(Yuwgna先修塔)
题解思路:细想就能知道:只要j或者k中有一个1,说明1~n(j,k除外)都能修,只要j或者k互质,那么肯定能修塔1(exgcd可证明),又回到了1状态,此时1~n(j,k除外)都能修。
还有一种情况就是j,k不互质,此时只要是gcd(j,k)的倍数都能修,求出n数内gcd(j,k)的倍数的个数(用到鸽笼原理/容斥原理),n/(gcd(j,k))判断奇偶性即可。
下面是AC代码:
#include<cstdio>
#include<iostream>
using namespace std;
int gcd(int a,int b)
{
    return b?gcd(b,a%b):a;
    }
int main()
{
    int t,tot=1;
    scanf("%d",&t);
    while(t--)
    {
              printf("Case #%d: ",tot++);
              int n,j,k;
              scanf("%d%d%d",&n,&j,&k);
              if(j==1||k==1||gcd(j,k)==1)
              {
                            n%2?printf("Yuwgna\n"):printf("Iaka\n");
                            continue;
                            }
              n/gcd(j,k)&1?printf("Yuwgna\n"):printf("Iaka\n");
              }
    return 0;
    }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值