1002 A+B for Polynomials (25)(25 分)

1002 A+B for Polynomials (25)(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

代码

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<map>
using namespace std;
double a[1005]={0},b[1005]={0},c[1005]={0};
int main()
{
	int k;int x;double y; 
	scanf("%d",&k);
	for(int i=1;i<=k;i++)
	{
		scanf("%d %lf",&x,&y);
		a[x]=y;
		c[x]++;
	}
	scanf("%d",&k);
	for(int i=1;i<=k;i++)
	{
		scanf("%d %lf",&x,&y);
		b[x]=y;
		c[x]++;
	}
	int cnt=0;
	for(int i = 0;i<=1000;i++)
	{
		c[i]=a[i]+b[i];
		if(c[i]!=0)cnt++;
	}
	cout<<cnt;
	for(int i = 1000;i>=0;i--)
	{
		if((a[i]+b[i])!=0)
		printf(" %d %.1lf",i,a[i]+b[i]);
	}
	cout<<endl;
	return 0 ;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值