1056 Mice and Rice (25)(25 分)

1056 Mice and Rice (25)(25 分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N~P~ programmers. Then every N~G~ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N~G~ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N~P~ and N~G~ (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N~G~ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N~P~ distinct non-negative numbers W~i~ (i=0,...N~P~-1) where each W~i~ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...N~P~-1 (assume that the programmers are numbered from 0 to N~P~-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

 

转载来自:https://blog.csdn.net/gemire/article/details/21558107

代码:

 

#include<bits/stdc++.h>
using namespace std;
int mice[1005],r[1005];
int main()
{
	int n, m, t;
	scanf("%d%d", &n, &m);
	for(int i = 0 ; i < n; i++)
		scanf("%d", &mice[i]);
	queue<int>qu;
	
	for(int i = 0; i < n ;i++)
	{
		scanf("%d",&t);
		qu.push(t);
	}
	while(qu.size() != 1 )
	{
		int cnt = qu.size() % m == 0 ? qu.size() / m : qu.size() / m + 1;
		int lorank = cnt+1;//这一轮比赛的失败者的排名
		
		queue<int>tmp;
		for(int i = 0 ; i < cnt ;i++)
		{
			int maxn = -1 ;
			int maxindex = -1;
			for(int j = i*m; j <i*m+m &&qu.size(); j++)
			{
				int in = qu.front();
				qu.pop();
				if(mice[in] > maxn)
				{
					maxn = mice[in];
					if(maxindex != -1)
						r[maxindex] = lorank;//这轮的排名 
					maxindex = in;
				}else 
					r[in] = lorank; 
			}
			tmp.push(maxindex);	
		} 
		qu = tmp;
	}
	r[qu.front()] = 1;
	for(int i = 0 ; i < n ; i ++)
		printf("%d%c",r[i]," \n"[i==n-1]);
	return 0;	
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值