1056 Mice and Rice(25 分)(C++)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

解题思路:分组比赛,注意以下几点

1.先考虑一下rank怎么来的,假设某次比赛有m人,每组为ng人,不难确定,可以分为group组(group为(m/ng)向上取整),就是说有group个赢家,剩下的人的排名自然就都是group+1;

2.从前往后,每ng为一组,每组的最重者有形成一个新的序列,用队列最方便。

3.initial playing order与输入的order之间的关系:输入的order是我们分组用的order,其实在比赛过程中,我们不用管initial playing order的,最后输出rank的时候按照initial playing order即可。

#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
int n, k, group, lastnum, maxn = -1, maxid, temp;
int main(){
	scanf("%d %d", &n, &k);
	vector<int>weight(n), rank(n);
	queue<int>mice;
	for(int i = 0; i < n; ++ i)
		scanf("%d", &weight[i]);
	for(int i = 0; i < n; ++ i){
		scanf("%d", &temp);
		mice.push(temp);
	}
	lastnum = n;
	while(mice.size() > 1){
		group = lastnum / k + (lastnum % k == 0 ? 0 : 1);
		for(int i = 1; i <= lastnum; ++i){
			temp = mice.front();
			if(maxn < weight[temp]){
				maxn = weight[temp];
				maxid = temp;
			}
			rank[temp] = group + 1;
			mice.pop();
			if(i % k == 0 || i == lastnum){
				maxn = -1;
				mice.push(maxid);
			}	
		}
		lastnum = mice.size();
	}
	rank[mice.front()] = 1;
	printf("%d", rank[0]);
	for(int i = 1; i < n; ++ i)
		printf(" %d", rank[i]);
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值