1020 Tree Traversals (25)(25 分)

1020 Tree Traversals (25)(25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

 

em.....先序和中序 利用先序 后序和中序利用后序

已知后序和中序 求层序遍历

代码:

#include<bits/stdc++.h>
using namespace std;
int post[45],in[45];
int level[45];
struct node
{
	int data;
	node *left,*right;
};
node* BuildTree(int* post,int* in,int pr,int pl,int il,int ir)
{
	if(pl > pr || il > ir) 
		return NULL;
	int pos;
	for(int i = il; i <= ir ; i++)
	{
		if(post[pr] == in[i])
		{
			pos = i;
			break;
		}
	}
	node *root = new node;
	root->data  = in[pos];
	root->left = root->right = NULL;
	root->left = BuildTree(post,in,pr-(ir-pos)-1,pl,il,pos - 1);
	root->right = BuildTree(post,in, pr-1,pr-(ir-pos),pos + 1,ir);
	return root;
}
void inorder(node *root) //验证
{
	if(root)
	{
		inorder(root->left);
		inorder(root->right);
		printf("%d----",root->data);
	}
	return ;
}
int main()
{
	int n;
	scanf("%d",&n);
	for(int i = 1; i <= n; i++)
		scanf("%d",&post[i]);
	for(int i = 1; i <= n; i++)
		scanf("%d",&in[i]);	
		
	struct node *root=NULL;
	root = BuildTree(post,in,n,1,1,n);
//	inorder(root);
	queue<node*>qu;
	qu.push(root);
	int now = 0;
	while(qu.empty() == 0)
	{
		node *tmp = qu.front();
		qu.pop();
		level[++now] = tmp->data;
		if(tmp->left) qu.push(tmp->left);
		if(tmp->right) qu.push(tmp->right);
	}
	for(int i = 1; i <= now;i++)
	{
		printf("%d%c",level[i]," \n"[i==now]);
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值