1020 Tree Traversals (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2
思路:

根据二叉树的后序、中序构建一个二叉树,然后输出它的层次序列

采用递归,会更容易建立二叉树

层序遍历用队列

C++:

#include "cstdio"
#include "iostream"
#include "cstring"
#include "queue"
#include "algorithm"
using namespace std;

const int maxn = 40;
int post[maxn], inor[maxn], pre[maxn];//后序、中序、前序序列
int n;//结点数
//二叉树结点
struct Node
{
	int data;
	Node* lchild;
	Node* rchild;
};
//当前二叉树的后序序列区间为[postL,postR],中序序列区间为[inL, inR]
//create 函数返回构建出的二叉树的根结点地址
Node* create(int postL, int postR, int inL,int inR){
	if(postL > postR){
		return NULL;//若后序序列长度小于等于0,则之间返回
	}
	Node* root = new Node;
	root->data = post[postR];//新结点的数据域为根结点的值
	int k;
	for (k = inL; k <= inR; k++)
	{
		if (inor[k] == post[postR])break;//在中序序列中找到inor[k]==post[postR]的结点
	}
	int numLeft = k - inL;//左子树结点个数
	root->lchild = create(postL, postL+numLeft-1, inL, k-1);
	root->rchild = create(postL+numLeft, postR-1, k+1, inR);
	return root;
}

int num = 0;
void BFS(Node* root){
	queue<Node*> q;
	q.push(root);
	while (!q.empty())
	{
		Node* now = q.front();
		q.pop();
		cout<<now->data;
		num++;
		if (num<n)
		{
			cout<<" ";
		}
		if (now->lchild!=NULL)
		{
			q.push(now->lchild);
		}
		if (now->rchild!=NULL)
		{
			q.push(now->rchild);
		}
	}
}
int main(){
	cin>>n;
	for (int i = 0; i < n; i++)
	{
		cin>>post[i];
	}
	for (int i = 0; i < n; i++)
	{
		cin>>inor[i];
	}
	Node* root = create(0, n-1, 0, n-1);
	BFS(root);//层序遍历
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值