1023 Have Fun with Numbers (20 分)
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.
Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:
For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.
Sample Input:
1234567899
Sample Output:
Yes
2469135798
大数类
import java.util.Scanner;
import java.math.*;
public class Main {
private static Scanner sc = new Scanner(System.in);
public static void main(String[] args){
String s = sc.next();
int num[] = new int[10];
for(int i = 0 ; i < s.length(); i ++)
num[s.charAt(i) - '0'] ++;
BigInteger a = new BigInteger(s) ; // 声明BigInteger对象
BigInteger c = new BigInteger("2");
BigInteger b = a.multiply(c);
String dd = b.toString();
for(int i = 0 ; i < dd.length(); i++)
num[dd.charAt(i) - '0'] --;
int flag = 0;
for(int i = 0 ; i < 10; i++)
{
if(num[i] != 0)
flag = 1;
}
if(flag == 1)
System.out.println("No");
else
System.out.println("Yes");
System.out.println(dd);
}
}