1067 Sort with Swap(0, i) (25 分)思路

1067 Sort with Swap(0, i) (25 分)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

经过演算发现有 0 的环是 n-1 没0的环是n+1当然了 个数要大于等于2才行

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5 + 10;
int digit[maxn], pre[maxn];
int cnt[maxn];
int find(int x){
	if(x == pre[x])
		return x;
	return pre[x] = find(pre[x]);
}
void merge(int x, int y)
{
	int fx = find(x);
	int fy = find(y);
	if(fx != fy){
		pre[fx] = fy;
	}	
} 
int main()
{
	ios::sync_with_stdio(false);
	int n;
	cin>>n;
	for(int i = 0; i < n ; i++)
	{
		cin>>digit[i];	
		pre[i] = i;
	}	
	for(int i = 0 ; i < n; i ++)
		merge(i , digit[i]);
	
	for(int i = 0; i < n; i ++)
		cnt[find(i)] ++;	
	int gg = cnt[find(0)];
	int kk = find(0);
	int ans = 0;
	if(gg != 1) //表明不是digit[0] = 0 
		ans = gg - 1; 
	for(int i = 0 ; i < n ; i++)
	{
		if(cnt[i] == 1 || i == kk || cnt[i] == 0)
			continue;
		ans = ans + cnt[i] + 1;	
	} 
	cout<<ans<<endl;
	
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值