1152 Google Recruitment (20 分)

1152 Google Recruitment (20 分)

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

prime.jpg

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

 

不难 就是如果答案是0023的话 那就要输出0023  别输出23我这边wa了。。。。原因是dd/10写成dd%10这个真不该错

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
bool is_Pr(int sum)
{
	if(sum == 2)
		return true;
	if(sum == 1)
		return false;
	int gg = sqrt(sum);
	for(int i = 2; i <= gg; i ++)
	{
		if(sum % i == 0)
			return false;
	}
	return true;
}
int main()
{
	int n, k ;
	scanf("%d %d",&n,&k);
	char str[1050];
	scanf("%s",str + 1);
	if(n < k)
	{
		printf("404\n");
		return 0;
	}
	int ans = 0;
	for(int i = 1; i <= k; i ++)
		ans = ans * 10 + str[i] - '0';
	int gg = 1;
	for(int i = 1; i < k; i ++)
		gg = gg * 10;
	if(is_Pr(ans))
	{
		printf("%d\n",ans);
		return 0;
	}	
	for(int i = k + 1; i <= n; i ++)
	{
		ans = ans % gg;
		ans = ans * 10 + str[i] - '0';
		if(is_Pr(ans))
		{
			int dd = ans,cnt = 0;
			while(1)
			{
				dd = dd / 10;
				cnt++;
				if(dd == 0)
					break;
			}
			for(int j = cnt + 1; j <= k; j++)
				printf("0");
			printf("%d\n",ans);
			return 0;
		}	
	}
	printf("404\n");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值