「1154」Vertex Coloring

proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than  ), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer  is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

Ω

给定一个无向图,判断顶点染色方案是否满足任意边的两个端点不同色,若满足则同时输出颜色数量。

在读取染色方案时,用set存储各个点不能染的颜色编号。读入顶点 的颜色 之后,先在 的set中find(c) ,如果找到了说明不满足要求,满足的话再将所有与 关联的顶点set中插入颜色 ,表明它不能染成颜色 。同时单独用一个set存储所有出现过的颜色来记录不同颜色数量。


🐎

#include <iostream>
#include <vector>
#include <set>

using namespace std;

int main()
{
    int n, m, a, b, k;
    scanf("%d %d", &n, &m);
    vector<vector<int>> edge(n);
    for (int i = 0; i < m; ++i)
    {
        scanf("%d %d", &a, &b);
        edge[a].push_back(b), edge[b].push_back(a);
    }
    scanf("%d", &k);
    for (int i = 0; i < k; ++i)
    {
        vector<set<int>> no(n);
        set<int> color;
        bool ans = true;
        for (int j = 0; j < n; ++j)
        {
            scanf("%d", &a);
            if (!ans) continue;
            ans = (no[j].find(a) == no[j].end());
            for (auto &t: edge[j])
                no[t].insert(a);
            color.insert(a);
        }
        if (ans) printf("%zu-coloring\n", color.size());
        else printf("No\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值