Excuses, Excuses!

题目:

Excuses, Excuses!
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4409 Accepted: 1512

Description

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input

Input to your program will consist of multiple sets of data. Line 1 of each set will contain exactly two integers. The first number (1 <= K <= 20) defines the number of keywords to be used in the search. The second number (1 <= E <= 20) defines the number of excuses in the set to be searched. Lines 2 through K+1 each contain exactly one keyword. Lines K+2 through K+1+E each contain exactly one excuse. All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L (1 <= L <= 20) and will occupy columns 1 through L in the input line. All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [".,!?] not including the square brackets and will not exceed 70 characters in length. Excuses will contain at least 1 non-space character.

Output

For each input set, you are to print the worst excuse(s) from the list. The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords. If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence. A keyword "occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space. 

For each set of input, you are to print a single line with the number of the set immediately after the string "Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order. After each set of output, you should print a blank line. 

Sample Input

5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?

Sample Output

Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!


心得:

学会使用sscanf函数对语句进行划分;

代码<C语言>:


#include<stdio.h>
#include<string.h>
int main()
{
    char str[70][100];
    int len[70];
    char key[25][25];
    int k,e;
    int t=0;
    int i,j;
    char tempkey[25];
    char temp[100];
    int maxlen;
    char *ptemp=NULL;// temp的指针
    while(scanf("%d%d",&k,&e)!=EOF)
    {
        maxlen=0;
        for(i=0; i<k; i++)
            scanf("%s",key[i]); // 读取关键字
        getchar();
        for(i=0; i<e; i++)
        {
            gets(str[i]);// 读取借口
            strcpy(temp,str[i]);// 借口复制给temp
            len[i]=0;
            // 处理借口,借口中不是字母的字符都替换成空格且大写转换为小写
            for(j=0; temp[j]!='\0'; j++)
            {
                if ((temp[j]>='a'&&temp[j]<='z')||(temp[j]>='A'&&temp[j]<='Z'))
                {
                    if(temp[j]>='A'&&temp[j]<='Z')
                    {
                        temp[j]=temp[j]+32;
                    }


                }
                else
                {
                    temp[j] =' ';
                }
            }
            //printf("转换后\n%s\n",temp);


            // 进行断句,将完整的句子分割为单词,单词暂存入temp中
            ptemp=temp;// 指针复位
            while(sscanf(ptemp,"%s",tempkey)>0)
            {
                ptemp++;// 跳过替换来的空格
                ptemp=ptemp+strlen(tempkey);// 指针的位置移动到下一个单词
                for(j=0; j<k; j++) // temp逐个与关键字进行比较
                    if(strcmp(tempkey,key[j])==0)
                        {
                            len[i]++;
                            //printf("配对的是%s\n",tempkey);
                        }
            }
            if(len[i]>len[maxlen])
                maxlen=i;
                //*ptemp=temp;
        }
        //for(i=0; i<k; i++)
        //printf("len[%d]的值为%d\n",i,len[i]);
        printf("Excuse Set #%d\n",++t);
        for(i=0; i<k; i++)
            if(len[i]==len[maxlen])
                printf("%s\n",str[i]);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值