利用SPFA算法解决PAT A1003

在刷题的时候发现Dijkstra经常会出现超时的情况,一般是使用Dijkstra堆优化或SPFA算法,还有的会使用链式前向星的方法存图都可以减少时间,下面给出SPFA的BFS算法,SPFA算法由Bellman算法演变而来,原理大致就是每当改变一个点的最短路径后,检测与这个点相邻的其他点的最短路径是否改变。

A1003 Emergency (25分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

大致题意:

第一行分别给出点数,边数,起点编号和终点编号

第二行给出每个点的权重

之后给出每个边的起点终点以及边的长度

现在求起点到终点的最短距离,如果最短距离有多条输出点权之和最大的 

注意点

SPFA和Bellman算法都有个共同点就是在求最短路径条数时,如果发现还有其他路径同样距离最短时要重新按照pre[]动态数组进行求和

题解

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<vector>
#include<set>
#include<map>
#include<stack>
#include<queue>

using namespace std;

const int N = 510;
const int INF = 0x3fffffff;

struct Node
{
	int v, dis;
	Node(int _v, int _dis) : v(_v), dis(_dis) {}
}; 

vector<Node> Adj[N];
int n, m, st, ed, weight[N];
int d[N], w[N], num[N];
set<int> pre[N];

bool vis[N] = {false}; 

bool SPFA(int s)
{
	fill(d, d + N, INF);
	memset(vis, false, sizeof(vis));
	memset(num, 0, sizeof(num));
	memset(w, 0, sizeof(w));
	
	queue<int> Q;
	Q.push(s);
	
	vis[s] = true;
	num[s] = 1;
	w[s] = weight[s];
	d[s] = 0;
	
	while(!Q.empty())
	{
		int u = Q.front();
		Q.pop();
		vis[u] = false;
		
		for(int i = 0; i < Adj[u].size(); i ++)
		{
			int v = Adj[u][i].v;
			int dis = Adj[u][i].dis;
			
			if(d[u] + dis < d[v])
			{
				d[v] = d[u] + dis;
				w[v] = w[u] + weight[v];
				num[v] = num[u];
				pre[v].clear();
				pre[v].insert(u);
				if(!vis[v])
				{
					Q.push(v);
					vis[v] = true;
				}
			}
			else if(d[u] + dis == d[v])
			{
				if(w[u] + weight[v] > w[v])
				{
					w[v] = w[u] + weight[v];
				}
				pre[v].insert(u);
				num[v] = 0;
				for(set<int>::iterator it = pre[v].begin(); it != pre[v].end(); it ++)
				{
					num[v] += num[*it];
				}
				if(!vis[v])
				{
					Q.push(v);
					vis[v] = true;
				}
			}
		}
	}
	return true;
}


int main()
{
//	freopen("test.txt","r",stdin);
	cin >> n >> m >> st >> ed;
	for(int i = 0; i < n; i ++)
	{
		cin >> weight[i];
	}
	
	int u, v, cost;
	
	for(int i = 0; i < m; i ++)
	{
		cin >> u >> v >> cost;
		Adj[u].push_back(Node(v, cost));
		Adj[v].push_back(Node(u, cost));
	}
	
	SPFA(st);
	
	cout<<num[ed]<<" "<<w[ed]<<endl;

	return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值