Program2_1020

 我现在做的是第二专题编号为1020的试题,具体内容如下所示:

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 22   Accepted Submission(s) : 14
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.<br><br>Note: the number of first circle should always be 1.<br><br><img src=../../data/images/1016-1.gif><br>
 

Input
n (0 < n < 20).<br>
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.<br><br>You are to write a program that completes above process.<br><br>Print a blank line after each case.<br>
 

Sample Input
  
  
6<br>8<br>
 

Sample Output
  
  
Case 1:<br>1 4 3 2 5 6<br>1 6 5 2 3 4<br><br>Case 2:<br>1 2 3 8 5 6 7 4<br>1 2 5 8 3 4 7 6<br>1 4 7 6 5 8 3 2<br>1 6 7 4 3 8 5 2<br>
 

Source
Asia 1996, Shanghai (Mainland China)
 
简单题意:两个相邻圆圈之和为素数

解题思路:从题意中不难看出,和以前的试题很相似,用dfs进行深搜,判断相邻的两个之和是否为素数

编写代码:#include <iostream>
#include <algorithm>
#include <string.h>
#include <cmath>
using namespace std;
const int maxn=25;
bool visit[maxn];
int num[maxn];
int n;

bool prime(int n)
{
  if(n==1)
    return false;
  if(n==2)
    return true;
  if(n%2==0)
    return false;
  for(int i=3;i<=(int)sqrt(n);i+=2)
    if(n%i==0)
    return false;
  return true;
}

void dfs(int step)
{
  if(step>n&&prime(num[n]+num[1]))
  {
    for(int i=1;i<=n-1;i++)
      cout<<num[i]<<" ";
    cout<<num[n]<<endl;
  }
  for(int i=2;i<=n;i++)
  {
    num[step]=i;
    if(prime(num[step]+num[step-1])&&!visit[i])
    {
      visit[i]=1;
      dfs(step+1);
      visit[i]=0;
    }
  }
}
int main()
{
  int c=1;
  while(cin>>n)
  {
    cout<<"Case "<<c++<<":"<<endl;
    memset(visit,0,sizeof(visit));
    num[1]=1;
    dfs(2);
    cout<<endl;
  }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值