SDAU课程练习2 1020

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 1
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.<br><br>Note: the number of first circle should always be 1.<br><br><img src=../../data/images/1016-1.gif><br>
 

Input
n (0 < n < 20).<br>
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.<br><br>You are to write a program that completes above process.<br><br>Print a blank line after each case.<br>
 

Sample Input
  
  
6<br>8<br>
 

Sample Output
  
  
Case 1:<br>1 4 3 2 5 6<br>1 6 5 2 3 4<br><br>Case 2:<br>1 2 3 8 5 6 7 4<br>1 2 5 8 3 4 7 6<br>1 4 7 6 5 8 3 2<br>1 6 7 4 3 8 5 2<br>
 

Source
Asia 1996, Shanghai (Mainland China)

 

题目大意:


给出一个数字。输出 从 1 开始,相邻数字都为素数的排列。 最后一个和第一个加起来也必须是素数。


思路:


看题目,给定的要求非常小,所以就可以把素数打成一个表,这样访问比较迅速。

然后就像数独那个题目一样。进行每个数字尝试就行了,满足条件继续,不满足就回溯到上一层继续。


感想:


这几个 dfs 的题卡了好久。。。

要不是我没日没夜刷,还真不知道啥时候能完。


AC代码:


#include<iostream>
#include<cstdio>
#include<stdio.h>
#include<cstring>
#include<cmath>
using namespace std;
int prime[40]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0};
int n,cou;
int num[25];
int vis [25];
int cc[25];
void dfs(int now)
{
    int i;
    if(now==n&&prime[1+cc[n]])
    {
        for(i=1;i<=n;i++)
        {
            if(i==1)
                cout<<cc[i];
            else
                cout<<" "<<cc[i];
        }
        cout<<endl;
    }
    else
    {
        for(i=2;i<=n;i++)
        {
            if(prime[i+cc[now]]&&!vis[i])
            {
                vis[i]=1;
                now++;
                cc[now]=i;
               //cout<<cc[now]<<"  "<<cc[now-1]<<endl;
                dfs(now);
                now--;
                vis[i]=0;
            }
        }
    }
}

int main()
{
    //freopen("r.txt","r",stdin);
    int i,j;
    cou=1;
    while(cin>>n)
    {

        cout<<"Case "<<cou<<":"<<endl;

        num[1]=cc[1]=1;
        for(i=2;i<=n;i++)
            num[i]=i;
        memset(vis,0,sizeof(vis));
        vis[1]=1;
        dfs(1);
        cou++;
        if(cou!=1)
            cout<<endl;

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值