zoj3623(更新顺序影响下的完全背包)

地址:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3623

Battle Ships

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produceN kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases. 
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers i(1 ≤ i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input
1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output
2
4
5

题意:打一个血量为v的小怪兽,可以建n种塔,每种塔耗时ti秒每秒打怪ai点血。最少要多少秒可以杀死小怪兽。

思路:以时间为容量,伤害的总血量为价值。因为塔可以在建造好后每一秒都造成伤害,所以建造同种塔的情况下,先后顺序会影响最终结果。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[700],vol[40],val[40];
int main()
{
    int n,v,i,j,ans;
    while(scanf("%d%d",&n,&v)>0)
    {
        memset(dp,0,sizeof(dp));
        for(i=0; i<n; i++)
            scanf("%d%d",&vol[i],&val[i]);
        ans=1100;
        for(i=0; i<n; i++)
        {
            for(j=vol[i]; ; j++)
            {
                if(dp[j-vol[i]]+(j-vol[i])*val[i]>dp[j])
                    dp[j]=dp[j-vol[i]]+(j-vol[i])*val[i];  //(j-vol[i])*val[i]只先建造种类为i的塔,然后再加上其后时间内的最优方案
                if(dp[j]>=v) break;
            }
            if(j<ans) ans=j;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值