Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.
Your job is to find out the minimum time the player should spend to win the game.
Input
There are multiple test cases.
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.
Output
Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.
Sample Input
1 1 1 1 2 10 1 1 2 5 3 100 1 10 3 20 10 100
Sample Output
2 4 5
题意:有n种船 给出造出每种船的时间 和 该船一秒可以打多少滴血,给出L总血量,问打到L滴血最少需要多少秒。
设dp[i] 代表第i秒最多可以打掉多少滴血 那么答案就是从第0秒开始枚举 找到第一个大于等于L的就结束。
dp[j+t[i]] = max{ dp[i+t[i]], dp[j] + l[i]*j }
#include <algorithm>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <set>
#include <map>
#include <cstring>
#include <cstdlib>
#include <iostream>
//#include <bits/stdc++.h>
#define MAX 0x3f3f3f3f
#define N 100005
#define M 200005
#define mod 1000000007
#define lson o<<1, l, m
#define rson o<<1|1, m+1, r
typedef long long LL;
using namespace std;
const double pi = acos(-1.0);
int n, m;
int t[40], l[40], dp[40000];
int main()
{
//freopen("in.txt","r",stdin);
while(~scanf("%d%d", &n, &m)) {
for(int i = 0; i < n; i++) {
scanf("%d%d", &t[i], &l[i]);
}
memset(dp, 0, sizeof(dp));
for(int i = 0; i < n; i++) {
for(int j = 0; j <= 340; j++) {
dp[ t[i] + j ] = max(dp[ t[i] + j ], dp[j] + j*l[i]);
}
}
for(int i = 0; i < 400; i++) {
if(dp[i] >= m) {
printf("%d\n", i);
break;
}
}
}
return 0;
}