hdu4336(概率DP+状态压缩)

地址:http://acm.hdu.edu.cn/showproblem.php?pid=4336

Card Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1988    Accepted Submission(s): 931
Special Judge


Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award. 

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks. 

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

Sample Input
  
  
1 0.1 2 0.1 0.4
 

Sample Output
  
  
10.000 10.500
 

题意:共有N张卡,每张卡存在于包中的概率为pi,每个包至多有一张卡(可能没有)。问买多少包才能凑齐所有卡片。

思路:将N张卡以二进制压缩开数组,剩下的按模板来。

代码:

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
//#include<algorithm>
using namespace std;
#define M 1<<21
double p[25],ans[M];
int main()
{
    int n;
    while(scanf("%d",&n)>0)
    {
        double h=1;
        for(int i=0;i<n;i++)
        {
            scanf("%lf",&p[i]);
            h-=p[i];  //没有抽到卡片的概率
        }
        int maxx=(1<<n)-1;
        ans[maxx]=0;
        for(int i=maxx-1;i>=0;i--)
        {
            double k=0;ans[i]=1;
            for(int j=0;j<n;j++)
            {
                if((1<<j)&i) k+=p[j];  //抽到已有卡片的概率
                else ans[i]+=p[j]*ans[i|(1<<j)];
            }
            ans[i]=(ans[i])/(1-h-k);
        }
        printf("%lf\n",ans[0]);  //注意这里
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值