hdu4336 Card Collector

http://www.elijahqi.win/archives/3618
Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, …, pN, (p1 + p2 + … + pN <= 1), indicating the possibility of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.

Sample Input
1 0.1 2 0.1 0.4

Sample Output
10.000 10.500

Source
2012 Multi-University Training Contest 4
一眼摩拜单车..可是怎么都套不进去 想起忘了谁曾经说过 期望倒着来 于是出奇迹设dp[s]表示收集了s状态的卡片 还期望收集多少卡片才能集齐 那么就有显然的转移了 但是存在自己转移到自己 所以先搞定其他牌 然后再算下自己系数即可 即把自己当成未知数

#include<cstdio>
#include<algorithm>
using namespace std;
double dp[1<<20],p[20];int n;
int main(){
    freopen("hdu4336.in","r",stdin);
    while(~scanf("%d",&n)){
        for (int i=0;i<n;++i) scanf("%lf",&p[i]);
        int S=(1<<n)-1;dp[S]=0;
        for (int s=S-1;~s;--s){double sum=0;dp[s]=0;
            for (int j=0;j<n;++j){
                if ((1<<j)&s) continue;sum+=p[j];
                dp[s]+=dp[s|(1<<j)]*p[j];
            }dp[s]=(dp[s]+1)/sum;
        }printf("%f\n",dp[0]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值