hdu1404(博弈搜索打表)

地址:http://acm.hdu.edu.cn/showproblem.php?pid=1404

Digital Deletions

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1764    Accepted Submission(s): 630


Problem Description
Digital deletions is a two-player game. The rule of the game is as following. 

Begin by writing down a string of digits (numbers) that's as long or as short as you like. The digits can be 0, 1, 2, 3, 4, 5, 6, 7, 8, 9 and appear in any combinations that you like. You don't have to use them all. Here is an example:



On a turn a player may either:
Change any one of the digits to a value less than the number that it is. (No negative numbers are allowed.) For example, you could change a 5 into a 4, 3, 2, 1, or 0. 
Erase a zero and all the digits to the right of it.


The player who removes the last digit wins.


The game that begins with the string of numbers above could proceed like this: 



Now, given a initial string, try to determine can the first player win if the two players play optimally both. 
 

Input
The input consists of several test cases. For each case, there is a string in one line.

The length of string will be in the range of [1,6]. The string contains only digit characters.

Proceed to the end of file.
 

Output
Output Yes in a line if the first player can win the game, otherwise output No.
 

Sample Input
  
  
0 00 1 20
 

Sample Output
  
  
Yes Yes No No
 

题意:给一串数字,两种操作方式。(1)是将某位不为零的数字变为比他小的数字,例如4可以变为1、2、3;(2)将某位为零的数字以及其右边的数字全部删去。不能操作的人失败,问先手是否胜利。

思路:因为只有长度为6的字符串,所以上来搜索,结果超时。然后建个表,将搜索的结果表存在表中避免第二次搜,A了。(有点状态压缩的感觉)

代码:

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define LL __int64
int ans[1000010];
int dfs(char ma[])
{
    if(ma[0]=='0') return 1;
    int len=strlen(ma);
    if(!len) return 0;
    int num=0;
    for(int i=0;i<len;i++) num*=10,num+=(ma[i]-'0');
    if(~ans[num]) return ans[num];
    for(int i=0;i<len;i++)
    {
        char mb[10];
        if(ma[i]=='0')
        {
            for(int j=0;j<i;j++)
                mb[j]=ma[j];
            mb[i]='\0';
            if(!dfs(mb)) return ans[num]=1;
        }
        else
        {
            strcpy(mb,ma);
            for(int j=0;j<ma[i]-'0';j++)
            {
                mb[i]=j+'0';
                if(!dfs(mb)) return ans[num]=1;
            }
        }
    }
    return ans[num]=0;
}
int main()
{
    memset(ans,-1,sizeof(ans));
    char a[10];
    while(scanf("%s",&a)>0)
        puts(dfs(a)?"Yes":"No");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值