hdu3586(树形DP+二分,割边)

地址:http://acm.hdu.edu.cn/showproblem.php?pid=3586

Information Disturbing

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)


Problem Description
In the battlefield , an effective way to defeat enemies is to break their communication system.
The information department told you that there are n enemy soldiers and their network which have n-1 communication routes can cover all of their soldiers. Information can exchange between any two soldiers by the communication routes. The number 1 soldier is the total commander and other soldiers who have only one neighbour is the frontline soldier.
Your boss zzn ordered you to cut off some routes to make any frontline soldiers in the network cannot reflect the information they collect from the battlefield to the total commander( number 1 soldier).
There is a kind of device who can choose some routes to cut off . But the cost (w) of any route you choose to cut off can’t be more than the device’s upper limit power. And the sum of the cost can’t be more than the device’s life m.
Now please minimize the upper limit power of your device to finish your task.
 

Input
The input consists of several test cases. 
The first line of each test case contains 2 integers: n(n<=1000)m(m<=1000000).
Each of the following N-1 lines is of the form:
ai bi wi
It means there’s one route from ai to bi(undirected) and it takes wi cost to cut off the route with the device.
(1<=ai,bi<=n,1<=wi<=1000)
The input ends with n=m=0.
 

Output
Each case should output one integer, the minimal possible upper limit power of your device to finish your task. 
If there is no way to finish the task, output -1.
 

Sample Input
  
  
5 5 1 3 2 1 4 3 3 5 5 4 2 6 0 0
 

Sample Output
  
  
3
 

题意:有n个阵地,其中1表示司令部,所有叶子节点表示前线,要求在切断前线与司令部联系所消耗的总值不大于m的情况下,问切断每条连线的的最小限制。(也就是说完成切断联系的每条边切断的消耗不大于限制,并且总消耗不大于m)

思路:树形DP+二分,利用树形DP求在不超过限制的情况下,切断联系的总消耗的最小值,然后根据最小值是否大于m来改变左右端点。

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
#define LL __int64
#define Ma 1010
struct node{
    int to,next,vi;
}tree[Ma*2];
int n,ma,len,head[Ma];
void add(int pa,int to,int vi){
    tree[len].to=to;
    tree[len].vi=vi;
    tree[len].next=head[pa];
    head[pa]=len++;
}
int dfs(int no,int pa,int k){
    int to,ans1=ma+1,ans2=0;  //ans1表示子节点与父亲节点的切断消耗,ans2表示子节点与其子节点的切断消耗
    for(int i=head[no];i!=-1;i=tree[i].next){
        to=tree[i].to;
        if(to==pa){
            if(tree[i].vi<=k) ans1=tree[i].vi;
            continue;
        }
        ans2+=dfs(to,no,k);
    }
    if(!ans2) ans2=ma+1;  //若连线切断消耗均大于限制,就将其总消耗赋值为ma+1
    return min(ans1,ans2);
}
int main(){
    while(scanf("%d%d",&n,&ma)>0,n|ma){
        memset(head,-1,sizeof(head));
        len=0;
        int l,r,v;
        for(int i=1;i<n;i++){
            scanf("%d%d%d",&l,&r,&v);
            add(l,r,v);
            add(r,l,v);
        }
        l=1,r=ma;
        while(l<=r){  //二分
            int mid=(l+r)/2;
            int k=dfs(1,-1,mid);
            if(k<=ma) r=mid-1;  //根据切断联系的总消耗的最小值来改变左右端点
            else l=mid+1;
        }
        printf("%d\n",l>ma?-1:l);  //注意-1对应的情况,我因为没有处理-1WA了一次
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值