hdu1175 暴力简单bfs

连连看

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13521    Accepted Submission(s): 3528


Problem Description
“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。
 

Input
输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!
 

Output
每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。
 

Sample Input
  
  
3 4 1 2 3 4 0 0 0 0 4 3 2 1 4 1 1 3 4 1 1 2 4 1 1 3 3 2 1 2 4 3 4 0 1 4 3 0 2 4 1 0 0 0 0 2 1 1 2 4 1 3 2 3 0 0
 

Sample Output
  
  
YES NO NO NO NO YES
 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

struct node{
	int x,y,f,g;
};

int map[1001][1001],n,m;
bool visit[1001][1001];          //运用bool型来定义标记

void bfs(node x,node y)
{
	queue<node> qi;
	node here,next;
	int yes=0;
	if(map[x.x][x.y]!=map[y.x][y.y]||map[x.x][x.y]==0||map[y.x][y.y]==0) printf("NO\n");  //在这里判断你要找的两个点的数值是否相同,或者是否为0
	else
	{
		qi.push(x);
		while(!qi.empty())
		{
			here=qi.front();
			qi.pop();
			visit[here.x][here.y]=true;
			if(here.x==y.x&&here.y==y.y&&here.g<=2)    //判断能否连通
			{
				printf("YES\n");
				yes=1;    //这里做个标记
				break;
			}
			if((here.x==x.x&&here.y==x.y)||(map[here.x][here.y]==0))    //在这里判断现在的点是初始点或者是不是为0,就是说能否通过这一点找到下一点
			{
				if(here.y+1<=m)
				{
					next.x=here.x;next.y=here.y+1;
					next.f=4;next.g=here.g;
					if(next.f!=here.f&&here.f!=0) next.g++;
					if(!visit[next.x][next.y]&&next.g<=2)
						qi.push(next);
				}
				if(here.x+1<=n)
				{
					next.x=here.x+1;next.y=here.y;
					next.f=3;next.g=here.g;
					if(next.f!=here.f&&here.f!=0) next.g++;
					if(!visit[next.x][next.y]&&next.g<=2)
						qi.push(next);
				}
				if(here.y>1)
				{
					next.x=here.x;next.y=here.y-1;
					next.f=2;next.g=here.g;
					if(next.f!=here.f&&here.f!=0) next.g++;
					if(!visit[next.x][next.y]&&next.g<=2)
						qi.push(next);
				}
				if(here.x>1)
				{
					next.x=here.x-1;next.y=here.y;
					next.f=1;next.g=here.g;
					if(next.f!=here.f&&here.f!=0) next.g++;
					if(!visit[next.x][next.y]&&next.g<=2)
						qi.push(next);
				}
			}
		}
		if(!yes) printf("NO\n");      //不能连通的话标记为0,就输出no
	}
}

int main()
{
	int t,i,j;
	node x,y;
	while(scanf("%d%d",&n,&m)>0,m,n)
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				scanf("%d",&map[i][j]);
		scanf("%d",&t);
		while(t--)
		{
			scanf("%d%d%d%d",&x.x,&x.y,&y.x,&y.y);
			memset(visit,false,sizeof(visit));    //memset可以将bool型的数组全部定义为true或false
			x.f=0;x.g=0;
			bfs(x,y);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值