hdu1067Gap(bfs)

7 篇文章 0 订阅

hdu1067Gap
Gap
Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1922 Accepted Submission(s): 978

Problem Description
Let’s play a card game called Gap.
You have 28 cards labeled with two-digit numbers. The first digit (from 1 to 4) represents the suit of the card, and the second digit (from 1 to 7) represents the value of the card.

First, you shu2e the cards and lay them face up on the table in four rows of seven cards, leaving a space of one card at the extreme left of each row. The following shows an example of initial layout.

Next, you remove all cards of value 1, and put them in the open space at the left end of the rows: “11” to the top row, “21” to the next, and so on.

Now you have 28 cards and four spaces, called gaps, in four rows and eight columns. You start moving cards from this layout.

At each move, you choose one of the four gaps and fill it with the successor of the left neighbor of the gap. The successor of a card is the next card in the same suit, when it exists. For instance the successor of “42” is “43”, and “27” has no successor.

In the above layout, you can move “43” to the gap at the right of “42”, or “36” to the gap at the right of “35”. If you move “43”, a new gap is generated to the right of “16”. You cannot move any card to the right of a card of value 7, nor to the right of a gap.

The goal of the game is, by choosing clever moves, to make four ascending sequences of the same suit, as follows.

Your task is to find the minimum number of moves to reach the goal layout.

Input
The input starts with a line containing the number of initial layouts that follow.

Each layout consists of five lines - a blank line and four lines which represent initial layouts of four rows. Each row has seven two-digit numbers which correspond to the cards.

Output
For each initial layout, produce a line with the minimum number of moves to reach the goal layout. Note that this number should not include the initial four moves of the cards of value 1. If there is no move sequence from the initial layout to the goal layout, produce “-1”.

Sample Input
4

12 13 14 15 16 17 21
22 23 24 25 26 27 31
32 33 34 35 36 37 41
42 43 44 45 46 47 11

26 31 13 44 21 24 42
17 45 23 25 41 36 11
46 34 14 12 37 32 47
16 43 27 35 22 33 15

17 12 16 13 15 14 11
27 22 26 23 25 24 21
37 32 36 33 35 34 31
47 42 46 43 45 44 41

27 14 22 35 32 46 33
13 17 36 24 44 21 15
43 16 45 47 23 11 26
25 37 41 34 42 12 31

Sample Output
0
33
60
-1

Source
Asia 2003(Aizu Japan)

Recommend
JGShining
反向bfs会爆,也许我写挫了?反正正着暴力一下就好了。。。

#include<bits/stdc++.h>
using namespace std;
string ed="1112131415161700212223242526270031323334353637004142434445464700";
int cnt=0;
unordered_map<string,int>mmp;
void swappos(string &tmp,int a,int b){
    swap(tmp[a<<1],tmp[b<<1]);
    swap(tmp[(a<<1)|1],tmp[(b<<1)|1]);
}
void ist(queue<string>&tmpq,string &tmp,int pos1,int pos2,int nwid){
    swappos(tmp,pos1,pos2);
    if(!mmp.count(tmp)){
        mmp[tmp]=nwid+1;
        tmpq.push(tmp);
        cnt++;
    }//else {cout<<"fuc"<<endl;}
}
int bfs(string st){
    mmp.clear();
    mmp[st]=0;
    queue<string>mq;
    mq.push(st);//cout<<st<<endl;
    while(!mq.empty()){
        string nw=mq.front();
        if(nw==ed)return mmp[nw];
        mq.pop();int nwid=mmp[nw];
        //cout<<nw<<endl;
        int pos[4],nxpos[4],f=0;
        memset(nxpos,-1,sizeof nxpos);
        for(int i=0;i<nw.length();i+=2){
            if(nw[i]=='0'){pos[f++]=i/2;}
        }
        for(int i=1;i<nw.length();i+=2){
            for(int j=0;j<4;j++){
                if(pos[j]>=1&&nw[i-1]==nw[pos[j]*2-2]&&nw[i]==nw[pos[j]*2-1]+1){
                    nxpos[j]=i/2;
                }
            }
        }
        for(int i=0;i<4;i++){
            if(nxpos[i]!=-1){
                ist(mq,nw,nxpos[i],pos[i],nwid);
                swappos(nw,nxpos[i],pos[i]);
            }
        }
    }
    return -1;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        string st="";
        for(int i=1;i<=4;i++){
            st+="00";
            for(int j=1;j<=7;j++){
                int p;
                scanf("%d",&p);
                st+=to_string(p);
            }
        }//cout<<st<<endl;
        for(int i=1;i<st.length();i+=2){
            if(st[i]=='1'){
                swappos(st,(i-1)/2,(int)(st[i-1]-'1')*8);
            }
        }
        printf("%d\n",bfs(st));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值