zoj2562(反素数)

地址:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2562

More Divisors

 

Time Limit: 2 Seconds        Memory Limit: 65536 KB

 

Everybody knows that we use decimal notation, i.e. the base of our notation is 10. Historians say that it is so because men have ten fingers. Maybe they are right. However, this is often not very convenient, ten has only four divisors -- 1, 2, 5 and 10. Thus, fractions like 1/3, 1/4 or 1/6 have inconvenient decimal representation. In this sense the notation with base 12, 24, or even 60 would be much more convenient.

The main reason for it is that the number of divisors of these numbers is much greater -- 6, 8 and 12 respectively. A good quiestion is: what is the number not exceeding n that has the greatest possible number of divisors? This is the question you have to answer.

Input:

The input consists of several test cases, each test case contains a integer n (1 <= n <= 1016).

Output:

For each test case, output positive integer number that does not exceed n and has the greatest possible number of divisors in a line. If there are several such numbers, output the smallest one.

Sample Input:

10
20
100

Sample Output:

6
12
60

 

题意:求n内的最小的反素数。

反素数概念:对于任何正整数x,其约数的个数记做g(x).例如g(1)=1,g(6)=4.如果某个正整数x满足:对于任意i(0<i<x),都有g(i)<g(x),则称x为反素数.

反素数性质:性质一:一个反素数的质因子必然是从2开始连续的质数.

                  性质二:p=2^t1*3^t2*5^t3*7^t4.....必然t1>=t2>=t3>=....

#include<cstdio>
#include<cmath>
#include<iostream>
using namespace std;
long long int maxx,maxa,m;
int prime[16]={0,2,3,5,7,11,13,17,19,23,29,31,37,41,43,47}; //这15个素数相乘就会大于10的16次方,所以在这个范围内找就行
void dfs(long long int sum,long long int ans,int k,int l)
{
	if(ans>maxx) {maxx=ans;maxa=sum;}
	else if(maxx==ans&&maxa>sum) maxa=sum;  //因子数相等时取最小的
	if(k>15) return ;
	for(int i=1;i<=l;i++)
	{
		sum*=prime[k];if(sum>m) break;
		dfs(sum,ans*(i+1),k+1,i);   //因为反素数的性质二,所以这里i是用来限定之后的质数因子数
	}
}
int main()
{
	while(scanf("%lld",&m)>0)
	{
		maxx=1;maxa=1;
		dfs(1,1,1,50);    //因为10的16次方不会超过2的50次方,所以这里设为50
		printf("%lld\n",maxa);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值