1606 - Amphiphilic Carbon Molecules

Shanghai Hypercomputers,the world's largest computer chip manufacturer, has invented a new class ofnanoparticles called Amphiphilic Carbon Molecules (ACMs). ACMs aresemiconductors. It means that they can be either conductors or insulators ofelectrons, and thus possess a property that is very important for the computerchip industry. They are also amphiphilic molecules, which means parts of themare hydrophilic while other parts of them are hydrophobic. Hydrophilic ACMs aresoluble in polar solvents (for example, water) but are insoluble in nonpolarsolvents (for example, acetone). Hydrophobic ACMs, on the contrary, are solublein acetone but insoluble in water. Semiconductor ACMs dissolved in either wateror acetone can be used in the computer chip manufacturing process.

As a materialsengineer at Shanghai Hypercomputers, your job is to prepare ACM solutions fromACM particles. You go to your factory everyday at 8 am and find a batch of ACMparticles on your workbench. You prepare the ACM solutions by dripping somewater, as well as some acetone, into those particles and watch the ACMsdissolve in the solvents. You always want to prepare unmixed solutions, so youfirst separate the ACM particles by placing an Insulating Carbon Partition Card(ICPC) perpendicular to your workbench. The ICPC is long enough to completelyseparate the particles. You then drip water on one side of the ICPC and acetoneon the other side. The ICPC helps you obtain hydrophilic ACMs dissolved inwater on one side and hydrophobic ACMs dissolved in acetone on the other side.If you happen to put the ICPC on top of some ACM particles, those ACMs will beright at the border between the water solution and the acetone solution, andthey will be dissolved. Fig.1 shows your working situation.

Fig.1

Your daily job isvery easy and boring, so your supervisor makes it a little bit more challengingby asking you to dissolve as much ACMs into solution as possible. You know youhave to be very careful about where to put the ICPC since hydrophilic ACMs onthe acetone side, or hydrophobic ACMs on the water side, will not dissolve. Asan experienced engineer, you also know that sometimes it can be very difficultto find the best position for the ICPC, so you decide to write a program tohelp you. You have asked your supervisor to buy a special digital camera andhave it installed above your workbench, so that your program can obtain theexact positions and species (hydrophilic or hydrophobic) of each ACM particlein a 2D pictures taken by the camera. The ICPC you put on your workbench willappear as a line in the 2D pictures.

Fig.2

Input 

There will be nomore than 10 test cases. Each case starts with a line containing an integer N,which is the number of ACM particles in the test case. N linesthen follow. Each line contains three integers xyr,where (xy) is the position of the ACM particlein the 2D picture and r can be 0 or 1, standing for thehydrophilic or hydrophobic type ACM respectively. The absolute value of xy willbe no larger than 10000. You may assume that N is no more than1000. N = 0 signifies the end of the input and need notbe processed. Fig.2 shows the positions of ACM particles and the best ICPCposition for the last test case in the sample input.

Output 

For each test case,output a line containing a single integer, which is the maximum number ofdissolved ACM particles.

Sample Input 

3

0 0 0

0 1 0

2 2 1

4

0 0 0

0 4 0

4 0 0

1 2 1

7

-1 0 0

1 2 1

2 3 0

2 1 1

0 3 1

1 4 0

-1 2 0

0

Sample Output 

3

3

6

代码:

//To make life abit easier, we change each color 1 point into color 0.

//Then we onlyneed to find an angle interval with most points. See code for details.

 

#include<cstdio>

#include<cmath>

#include<cstring>

#include<algorithm>

using namespacestd;

 

const int maxn =1000 + 5;

 

struct Point

{

    int x, y;

    double rad;// with respect to current point

    bool operator<(const Point &rhs)const

    {

        return rad < rhs.rad;

    }

} op[maxn],p[maxn];

 

int n,color[maxn];

 

//from O-A to O-B,is it a left turn?

bool Left(Point A,Point B)

{

    return A.x * B.y - A.y * B.x >= 0;

}

 

int solve()

{

    if(n <= 2)

    {

        return 2;

    }

    int ans = 0;

//pivot point

    for(int i = 0; i < n; i++)

    {

        int k = 0;

//the list ofother point, sorted in increasing order of rad

        for(int j = 0; j < n; j++)

        {

            if(j != i)

            {

                p[k].x = op[j].x - op[i].x;

                p[k].y = op[j].y - op[i].y;

                if(color[j])

                {

                    p[k].x = -p[k].x;

                    p[k].y = -p[k].y;

                }

                p[k].rad = atan2(p[k].y,p[k].x);

                k++;

            }

        }

        sort(p, p+k);

//sweeping. cnt isthe number of points whose rad is between p[L] and p[R]

        int L = 0, R = 0, cnt = 2;

        while(L < k)

        {

            if(R == L)

            {

                R = (R+1)%k;   // empty interval

                cnt++;

            }

            while(R != L && Left(p[L],p[R]))

            {

                R = (R+1)%k;  //  stop when [L,R] spans across > 180 degrees

                cnt++;

            }

            cnt--;

            L++;

            ans = max(ans, cnt);

        }

    }

    return ans;

}

 

int main()

{

    while(scanf("%d", &n) == 1&& n)

    {

        for(int i = 0; i < n; i++)

        {

            scanf("%d%d%d",&op[i].x, &op[i].y, &color[i]);

        }

        printf("%d\n", solve());

    }

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值