Supermarket
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 8614 | Accepted: 3701 |
Description
A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ
x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.
Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.
Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4 50 2 10 1 20 2 30 1 7 20 1 2 1 10 3 100 2 8 2 5 20 50 10
Sample Output
80 185
Hint
The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.
代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
#define Maxn 10010
using namespace std;
struct pro{
int px,dx;
friend bool operator<(const pro &a,const pro &b){return a.px>b.px;}
}p[Maxn];
int fa[Maxn];
int findset(int x){return fa[x]==x?x:(fa[x]=findset(fa[x]));}
int main()
{
int n;
while(cin>>n){
int ans=0;
for(int i=1;i<=n;i++)
scanf("%d%d",&p[i].px,&p[i].dx);
for(int i=1;i<Maxn;i++) fa[i]=i;
sort(p+1,p+n+1);
for(int i=1;i<=n;i++){
int f=findset(p[i].dx);
if(f>0) ans+=p[i].px,fa[f]=f-1;
}
cout<<ans<<endl;
}
}
注:这题是贪心算法,但是用到了并查集优化,非常神奇,这个用法还是第一次见到,这题的这个用法把并查集阐述得淋漓尽致。每个查集都记录下次可用的deadline。