PAT-1015 Reversible Primes【进制转换】【素数判定】

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

很简单,第一步,进制转换(十进制变某进制,某进制转十进制),第二部判断是否为素数。 


#include <stdio.h>
#include <iostream>
#include <queue>
#include <math.h>
using namespace std;

int isPrime(int n){
    if(n <= 1) return false;               //再次强调一下,边界很重要
    for(int i = 2, l = (int)sqrt(n); i <= l; i++){
        if(n % i == 0){
            return false;
        }
    }
    return true;
}
int getReverse(int num,int base){
	queue<int> stu;
	int shang,yushu;
	while(num/base){
		yushu=num%base;
		num/=base;
		stu.push(yushu);
	}
	stu.push(num);
	int sum=0;
	for(int i=stu.size()-1;i>=0;i--){
		sum+=stu.front()*pow(base,i);
		stu.pop();
	}
	return sum;
}
int main(){
	int a,b;
	scanf("%d",&a);
	while(a>0){
		scanf("%d",&b);
		if(isPrime(a)==1){
			if(isPrime(getReverse(a,b))==1){
				cout<<"Yes"<<endl;
			}else{
				cout<<"No"<<endl;
			}
		}else{
			cout<<"No"<<endl;
		}
		scanf("%d",&a);
	}
	return 0;
}

按照测试用例的边界一说,关于素数的判断,一定有对于,1的考验。因为理所当然的觉得这个不会出现,结果一个测试用例没做出来,扣了2分 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值