PAT-A1058 A+B in Hogwarts【进制转换】【字符查找】

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28
#include <iostream>
#include <string>
using namespace std;
int low=0;
int middle=0;
int high=0;
void getAdd(string s){
	int index1=s.find_first_of('.');
	int index2=s.find_last_of('.');
	low+=atoi(s.substr(index2+1,s.size()-index2-1).c_str());
	if(low>=29){
		low-=29;
		middle+=1;
	}
	middle+=atoi(s.substr(index1+1,index2-index1-1).c_str());
	if(middle>=17){
		middle-=17;
		high+=1;
	}
	high+=atoi(s.substr(0,index1).c_str());
	
}
int main(){
	string one;
	string two;
	cin>>one;
	cin>>two;
	getAdd(one);
	getAdd(two);
	cout<<high<<"."<<middle<<"."<<low<<endl;
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值