PAT-A1035 Password【字符串处理】

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

 只要注意一点就好了:使用find只能返回第一个符合的下标,如果要全部找到,需要使用while循环

实际上find函数需要两个参数:、

string的find()函数用于找出字母在字符串中的位置。

find(str,position)

find()的两个参数:

str:是要找的元素

position:字符串中的某个位置,表示从从这个位置开始的字符串中找指定元素。

可以不填第二个参数,默认从字符串的开头进行查找

返回值为目标字符的位置,当没有找到目标字符时返回npos

 

#include <iostream>
#include <string>
#include <vector>
using namespace std;
vector<string> password;
bool contain(string s){
	int n=s.npos;
	int one=s.find('1');
	int zero=s.find('0');
	int l=s.find('l');
	int O=s.find('O');
	if(one!=n||zero!=n||l!=n||O!=n){
		
		if(one!=n){
			int index=one+1;
			s[one]='@';
			while(true){
				int temp=s.find('1',index);
				if(temp==n){
					break;
				}
				s[temp]='@';
				index=temp+1;
			}
		}
		if(zero!=n){
			int index=zero+1;
			s[zero]='%';
			while(true){	
				int temp=s.find('0',index);
				if(temp==n){
					break;
				}
				s[temp]='%';
				index=temp+1;
			}
		}
		if(l!=n){
			int index=l+1;
			s[l]='L';
			while(true){
				int temp=s.find('l',index);
				if(temp==n){
					break;
				}
				s[temp]='L';
				index=temp+1;
			}
		}
		if(O!=n){
			int index=O+1;
			s[O]='o';
			while(true){
				int temp=s.find('O',index);
				if(temp==n){
					break;
				}
				s[temp]='o';
				index=temp+1;
			}
		}
		password.push_back(s);
		return true;
	}

	return false;

}
int main(){
	int n;
	scanf("%d",&n);
	string a,b;
	vector<string> name;
	for(int i=0;i<n;i++){
		cin>>a>>b;
		if(contain(b)){
			name.push_back(a);
		}
	}
	int nn=name.size();
	if(n==1&&nn==0){
		printf("There is 1 account and no account is modified\n");
		return 0;
	}
	if(nn==0){
		printf("There are %d accounts and no account is modified\n",n);
		return 0;
	}
	printf("%d\n",name.size());
	for(int j=0;j<name.size();j++){
		printf("%s",name[j].c_str());
		printf(" %s\n",password[j].c_str());
	}
	
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值