PAT-A- 1073 Scientific Notation 【科学计数法】

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

科学计数法,将道理说起来不难,但是操作起来怎么这么麻烦呢 

#include<iostream>
#include <string>
using namespace std;
int main(){
    string sci;
	cin>>sci;
	if(sci[0]=='-') printf("-");
	int index_E=sci.find('E');
	int times=atoi(sci.substr(index_E+2).c_str());
	if(sci[index_E+1]=='-'){
		if(sci[1]=='0')
		{
			printf("0.");
			for(int i=0;i<times;i++){
				printf("0");
			}
			for(int j=3;j<index_E;j++){
				printf("%c",sci[j]);
			}
		}
		else{
			printf("0.");
			for(int i=0;i<times-1;i++){
				printf("0");
			}
			printf("%c",sci[1]);
			for(int j=3;j<index_E;j++){
				printf("%c",sci[j]);
			}
		}
	}
	else{
		if(sci[1]=='0'){
			int jingdu=index_E-3;
			if(jingdu<=times){
				for(int z=3;z<index_E;z++){
					printf("%c",sci[z]);
				}
				for(int x=times-jingdu;x>0;x--){
					printf("0");
				}
			}else{
				for(int c=0;c<times;c++){
					printf("%c",sci[c+3]);
				}
				printf(".");
				for(int v=0;v<jingdu-times;v++){
					printf("%c",sci[3+times+v]);
				}
			}
		}
		else{
			int jingdu=index_E-3;
			if(jingdu<=times){
				for(int b=1;b<index_E;b++){
					if(b==2) continue;
                    printf("%c",sci[b]);
				}
				for(int p=0;p<times-jingdu;p++){
					printf("0");
				}
			}
			else{
				printf("%c",sci[1]);
				for(int t=0;t<times;t++){
					printf("%c",sci[3+t]);
				}
				printf(".");
				for(int y=0;y<jingdu-times;y++){
					printf("%c",sci[3+times+y]);
				}
			}
		}
	}
    
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值