PAT-A-1093 Count PATs 【复习】

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

思路:

从左向右遍历,记录每个位置及左边P出现的次数

从右向左遍历,记录每个位置右边T出现的次数,如果是A,同时计算。

#include <iostream>
#include <vector>
#include <math.h>
#include <string>
using namespace std;
int main(){
	string data;
	int numOfLeftN[100001];
	cin>>data;
	int size=data.size();
	for(int i=0,t=0;i<size;i++){
		if(data[i]=='P') t++;
		numOfLeftN[i]=t;
	}
	
	long res=0;
	for(int j=size-1,x=0;j>=0;j--){
		if(data[j]=='T') x++;
		else if(data[j]=='A'){
			res+=(x*numOfLeftN[j])%1000000007;
		}
	}
	printf("%ld",res%1000000007);
return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值