PAT-A-1033 To Fill or Not to Fill 【贪心算法】

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

一个很巧妙的思路,按照贪心算法,为了达到路费最少,总是尽可能保障在油费最少的地方加满油,否者邮箱里的右刚好到下一站。

使用flag数组来标志路程是否可达,初始化0表示都不可达,假如到了某一加油站加了油之后,从该站到杭州的距离开始到汽车能跑的距离置为1;由于是贪心算法,即总是先满足油费最低的加油站,给结构体按照油费递增排序。然后按照上述思路开始给flag赋值。

遍历输出的时候,如果某一位置flag为0,即无论加油,该位置不可达return掉 


#include <iostream>
#include <vector>
#include <string>
#include <stack>
#include <queue>
using namespace std;
struct station{               //保存加油站信息
	double price;
	int distance;
}sta[501];
bool cmp(const station s1,const station s2){
	return s1.price<s2.price;
}
int main(){
	int cap,dis,cost,num;
	int flag[30001]={0};         //!!!判断是否可达
	double sum=0;
	scanf("%d %d %d %d",&cap,&dis,&cost,&num);
	for(int i=0;i<num;i++){
		scanf("%lf %d",&sta[i].price,&sta[i].distance);
	}
	sort(sta,sta+num,cmp);
	int max,cnt;
	for(int  j=0;j<num;j++){      //总是尽可能多加油,能加一箱肯定加一箱,用不了一箱,用多少 
                                  //加多少
		if(cap*cost+sta[j].distance>dis) max=dis-sta[j].distance;
		else max=cap*cost;
		cnt=0;
		for(int index=sta[j].distance;index<max+sta[j].distance;index++){
			if(flag[index]==0){
				flag[index]=1;
				cnt++;
			}
		}
		sum+=cnt/(cost*1.0)*sta[j].price;           //这一步很关键,cnt加出来的结果是里程
	}                                               //需要除以油耗
	for(int k=0;k<dis;k++){
		if(flag[k]==0){
			printf("The maximum travel distance = %.2lf\n", (double)k);
			return 0;
		}
	}
	printf("%.2lf\n",sum);
	return 0;
}

 

深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值