PAT-A-1071 Speech Patterns 【散列】

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

典型的散列思想,但是细节很多。

  •  题目中给出的数据上限是1048576,这个数怎么特殊了呢,1048576=1024*1024,如果直接定义成静态数组那么程序会崩掉的,有兴趣的可以了解下char数组的最大长度(静态),所以只能使用new来动态申请地址。因为使用fgets读取数据,会将换行符也读进来,因此在上限加1位,为什么我加了2呢?因为我就是单纯的想加2
  • 遍历字符数组,使用string 保存连续的字符串形成单词,那么什么样的字符可以加进来呢?题目说的很明白了,[65,90],[97,122],[48,57].如果不是上述这些字符,进入下一部
  • 对string进行判断,判断是不是空,如果不是空对其进行小写转换,这个不用慌,<algorithm>下面定义了大小写转换的函数transform(),四个参数,inputstart_index,inputend_index,outputstart_index,method,其中method有两个方法,分别是         ::tolower,::toupper,注意有::,究其原因:tolower和toupper 分别在两个地方定义了。一个是 std::tolower ,一个是在 cctype中定义的。如果单纯使用 tolower ,编译器会使用去加载这个 std::tolower ,而 std::tolower的原型是: charT toupper (charT c, const locale& loc); ,不符合transform函数的第四个参数。因此我们需要给他变型一下。也就是上面被注释掉的代码。如果要使用 cctype中的 tolower ,就直接用全局定义 :: ,即可。//transform(input.begin(), input.end(), upper.begin(), (int (*)(int))std::toupper);
  • 一个细节:便利完之后退出循环,这时候一定要再次判断string是否为空,因为按照遍历的逻辑,到最后一个字符就结束了,因此此时string可能不为空
  • 然后就是散列
#include <iostream>
#include <string>
#include <map>
#include <algorithm>
#define maxsize 1048578
using namespace std;
int main() {
	char *stu = new char[maxsize];
	map<string, int> res;
	fgets(stu, maxsize, stdin);
	int size = strlen(stu) - 1;
	string temp = "";
	for (int i = 0; i < size; i++) {
		if ((65 <= stu[i] && stu[i] <= 90) || (97 <= stu[i] && stu[i] <= 122) || (48 <= stu[i] && stu[i] <= 57)) temp += stu[i];
		else {
			if (temp.size() != 0) {
				transform(temp.begin(), temp.end(),temp.begin(),::tolower);
				res[temp] += 1;
				temp = "";
			}
		}
	}
	if (temp.size() != 0) {
				transform(temp.begin(), temp.end(),temp.begin(),::tolower);
				res[temp] += 1;
		
	}
	int max = -1;
	string ss;
	for (map<string, int>::iterator lt = res.begin(); lt != res.end(); lt++) {
		if (lt->second > max) {
			max = lt->second;
			ss = lt->first;
		}
	}
	printf("%s %d", ss.c_str(), max);
	delete stu;
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值