PAT-A-1085 Perfect Sequence 【二分查找】

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

这道题使用upper_bound简直绝了。原因如下:

  • upper_load()返回的是第一个大于所求值得下标,直接减去数组头就是序列的长度
  • 内部使用二分查找,速度绝对杠杠的

最后一个用例点没有过,因为没有考虑过int溢出的问题,其实一看到题目中指定了数据的范围是1e9,就应该知道这里有猫腻。

使用long long 保存乘积

#include <iostream>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
int main(){
	int a,b;
	scanf("%d %d",&a,&b);
	int temp;
	vector<int> data;
	for(int i=0;i<a;i++){
		scanf("%d",&temp);
		data.push_back(temp);
	}
	int max=-1;
	sort(data.begin(),data.end());
	for(int j=0;j<data.size();j++){	
			int len=upper_bound(data.begin()+j+1,data.end(),(long long)b*data[j])-data.begin();
			max=max>len-j?max:len-j;
	}
	printf("%d",max);
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值