Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.
Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤109) is the parameter. In the second line there are N positive integers, each is no greater than 109.
Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8
这道题使用upper_bound简直绝了。原因如下:
- upper_load()返回的是第一个大于所求值得下标,直接减去数组头就是序列的长度
- 内部使用二分查找,速度绝对杠杠的
最后一个用例点没有过,因为没有考虑过int溢出的问题,其实一看到题目中指定了数据的范围是1e9,就应该知道这里有猫腻。
使用long long 保存乘积
#include <iostream>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
int main(){
int a,b;
scanf("%d %d",&a,&b);
int temp;
vector<int> data;
for(int i=0;i<a;i++){
scanf("%d",&temp);
data.push_back(temp);
}
int max=-1;
sort(data.begin(),data.end());
for(int j=0;j<data.size();j++){
int len=upper_bound(data.begin()+j+1,data.end(),(long long)b*data[j])-data.begin();
max=max>len-j?max:len-j;
}
printf("%d",max);
return 0;
}