A Simple Problem with Integers(线段树)

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C abc" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q ab" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

解题思路

线段树的区间更新,用到了lazy思想,先贴上百度百科里的解释:

这里会遇到一个问题:为了使所有sum值都保持正确,每一次插入操作可能要更新O(N)个sum值,从而使时间复杂度退化为O(N)。

解决方案是Lazy思想:对整个结点进行的操作,先在结点上做标记,而并非真正执行,直到根据查询操作的需要分成两部分。

根据Lazy思想,我们可以在不代表原线段的结点上增加一个值toadd,即为对这个结点,留待以后执行的插入操作k值的总和。

对整个结点插入时,只更新sum和toadd值而不向下进行,这样时间复杂度可证明为O(logN)。

对一个toadd值为0的结点整个进行查询时,直接返回存储在其中的sum值;

而若对toadd不为0的一部分进行查询,则要更新其左右子结点的sum值,然后把toadd值传递下去,再对这个查询本身,左右子结点分别递归下去。

时间复杂度也是O(nlogN)。

用自己的话讲就是,add[]是个标记,表示从本身向上都已经执行过本次更新,下面的还没有,add[]表示区间内所有元素都要更新的值;

所以查询时,如果在查询区间内  且  add[]值为0,直接返回区间值,若add[]值不为0,就把add[]值向下传递。

update和query的思路差不多


AC代码

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
const int maxn = 100005;
long long sum[maxn << 2];
long long add[maxn << 2];
int n, T;
void PushUp(int rt)
{
    sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}
void PushDown(int rt,int m)
{
    if(add[rt])
    {
        add[rt << 1] += add[rt];
        add[rt << 1 | 1] += add[rt];
        sum[rt << 1] += add[rt] * (m - (m >> 1));    //注意左右区间的大小
        sum[rt << 1 | 1] += add[rt] * (m >> 1);
        add[rt] = 0;                                 //传递add[]之后,本身赋成0
    }
}
void build(int l, int r, int rt)
{
    add[rt] = 0;                                     //初始add[]都赋值成0
    if(l == r)
    {
        scanf("%lld", &sum[rt]);
        return ;
    }
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
    PushUp(rt);
}

void update(int L, int R, int d, int l, int r, int rt)
{
    if(L <= l && r <= R)
    {
        add[rt] += d;                          //如果区间在更新区间内,停止向下查找,更新add[]值和sum[]值
        sum[rt] += (long long)d * (r - l + 1);
        return;
    }
    PushDown(rt, r - l + 1);                //未找到满足的区间,就一直向下传递非0的add[]值
    int m = (r + l) >> 1;
    if(L <= m)
        update(L, R, d, lson);
    if(R > m)
        update(L, R, d, rson);
    PushUp(rt);                              //记住向上更新
}

long long query(int L, int R, int l, int r, int rt)
{
    if(L <= l && r <= R)
    {
        return sum[rt];
    }
    PushDown(rt, r - l + 1);
    int m = (l + r) >> 1;
    long long  ans = 0;
    if(L <= m)
        ans += query(L, R, lson);
    if(R > m)
        ans += query(L, R, rson);
    return ans;
}
int main()
{
    scanf("%d%d", &n, &T);
    build(1, n, 1);
    char ch;
    int a, b, d;
    while(T--)
    {
        getchar();                      //注意吃回车,或者下面用%s输入
        scanf("%c", &ch);
        if(ch == 'Q')
        {
            scanf("%d%d", &a, &b);
            printf("%lld\n", query(a, b, 1, n, 1));
        }
        else
        {
            scanf("%d%d%d", &a, &b, &d);
            update(a, b, d, 1, n, 1);
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值