PATA 1020 Tree Traversals (25)

16 篇文章 0 订阅

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
总体思路:利用后序遍历序列和中序遍历序列先还原树,然后利用队列实现层次遍历。

代码如下:

#include<iostream>
#include<cstdio>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
struct  node
{
    node* lchild;
    node* rchild;
    int   data;
};
node tree[100];
int loc(0);
node* create()
{
    tree[loc].lchild = tree[loc].rchild = NULL;
    return &tree[loc++];
}
void levelOrder(node* T)
{
    queue<node*> que;
    node* p;
    que.push(T);
    int flag = 0;
    while (!que.empty())
    {
        p = que.front();
        que.pop();
        if (flag == 0)
            cout << p->data;
        else
            cout << " " << p->data;
        flag++;
        if (p->lchild != NULL)
            que.push(p->lchild);
        if (p->rchild != NULL)
            que.push(p->rchild);
    }
}
vector<int> post;
vector<int> in;
//由后序和中序遍历序列还原树,并返回根结点s2,e2为后序遍历起终点,s1,e1为中序遍历起终点
node* build(int s1, int e1, int s2, int e2)
{
    node* ret = create();
    ret->data = post[e2];
    int rootidx;
    for (int i = s1; i <= e1; i++)
    {
        if (in[i] == post[e2])
        {
            rootidx = i;
            break;
        }
    }
    //注意确定左子树在后序序列中的位置时,s2要加上的一定是一个相对量,也即左子树结点的个数减1!!!
    if (rootidx != s1)//左子树非空
    {
        ret->lchild = build(s1, rootidx - 1, s2, s2+rootidx-s1-1);
    }
    //确定右子树时也是同理,s2要加上的值一定要计算清楚!!!
    if (rootidx != e1)//右子树非空
    {
        ret->rchild = build(rootidx+1,e1,s2+rootidx-s1,e2-1);
    }
    return ret;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("D:\\in.txt", "r", stdin);
    freopen("D:\\out.txt", "w", stdout);
#endif
    int N(0);
    cin >> N;
    int t(0);
    for (int i = 0; i < N; i++)
    {
        cin >> t;
        post.push_back(t);
    }
    for (int i = 0; i < N; i++)
    {
        cin >> t;
        in.push_back(t);
    }
    int len1 = in.size();
    int len2 = post.size();
    int loc = 0;
    node* T = build(0, len1 - 1, 0, len2 - 1);
    levelOrder(T);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值