1005 Spell It Right

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

中文题意 

给定一个非负整数 N,你的任务是计算所有数字的总和N,用英语输出总和的每一位数。

输入规格:

每个输入文件包含一个测试用例。每个案例占一行包含一个N(≤10​100​​).

输出规格:

对于每个测试用例,在一行中输出英文单词中总和的数字。两个连续的单词之间必须有一个空格,但在一行的末尾没有多余的空格。

 题目不难直接上代码:

#include <iostream>
#include <string>
#include <cstring>
#include <cmath>
using namespace std;
void english(int a)//把数字转化为英文单词
{
	switch(a)
	{
		case 0:cout<<"zero";break;
		case 1:cout<<"one";break;
		case 2:cout<<"two";break;
		case 3:cout<<"three";break;
		case 4:cout<<"four";break;
		case 5:cout<<"five";break;
		case 6:cout<<"six";break;
		case 7:cout<<"seven";break;
		case 8:cout<<"eight";break;
		case 9:cout<<"nine";break;	
	}
}
int sum1[100000000];
int main()
{
	string s;
	long long sum=0;
	cin>>s;
	for(long long i=0;i<s.length();i++)
	{
		sum=sum+s[i]-'0';//累加
	}
	long long j=0;
	while(sum!=0)
	{
		sum1[j]=sum%10;
		sum/=10;
		j++;
	}
	bool pd=false;
	if(j==0)
		english(0);
	for(long long i=j-1;i>=0;i--)
	{
		if(sum1[i]!=0||pd)
		{
			english(sum1[i]);
			if(i!=0)
				cout<<" ";
			pd=true;	
		}
		
	}
	return 0;
} 

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值