PTA甲级 1005 Spell It Right (C++)

Given a non-negative integer N N N, your task is to compute the sum of all the digits of N N N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N ( ≤ 1 0 100 ) N (≤10 ^{100}) N(10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-10 11:09:31
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

string digit[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};

int main(){
    string s, ans = "";
    
    int sum = 0;
    
    // scanf("%s", &s);
    cin >> s;
    for(int i = 0; i < s.length(); ++i){
        sum += s[i] - '0';
    }

    if(sum == 0){
        cout << "zero" << endl;
        return 0;
    }

    while(sum != 0){
        ans = digit[sum % 10] + ans;
        sum /= 10;
        if(sum != 0) ans = " " + ans;
    }

    cout << ans << endl;

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值