#1130. Infix Expression【树的遍历】

原题链接

Problem Description:

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N N N ( ≤ 20 \leq 20 20) which is the total number of nodes in the syntax tree. Then N N N lines follow, each gives the information of a node (the i i i-th line corresponds to the i i i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node’s left and right children, respectively. The nodes are indexed from 1 to N N N. The NULL link is represented by − 1 −1 1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.
在这里插入图片描述
在这里插入图片描述

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

Problem Analysis:

中缀表达式树进行中序遍历就可得到表达式,如果需要添加优先级括号的话,只要当前节点不是叶子节点且不是根节点,就可以添加括号。

Code

#include <iostream>
#include <algorithm>
#include <cstring>
#include <unordered_map>

using namespace std;

const int N = 30;

int n;
unordered_map<int, int> l, r;
string w[N], res;
bool st[N];
int root = 1;

void dfs(int u)
{
    bool flag = false;
    if ((~l[u] || ~r[u]) && u != root)
    {
        res += "(";
        flag = true;
    }
    
    if (~l[u]) dfs(l[u]);
    res += w[u];
    if (~r[u]) dfs(r[u]);

    if (flag) res += ")";
}

int main()
{
    cin >> n;
    for (int i = 1; i <= n; i ++ )
    {
        cin >> w[i] >> l[i] >> r[i];
        if (~l[i]) st[l[i]] = true;
        if (~r[i]) st[r[i]] = true;
    }

    while (st[root]) root ++ ;

    dfs(root);
    cout << res << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值