#1055. The World‘s Richest【堆 + 多路归并】

原题链接

Problem Description:

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N N N people, you must find the M M M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N N N ( ≤ 1 0 5 \leq 10^5 105) - the total number of people, and K K K ( ≤ 1 0 3 \leq 10^3 103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in ( 0 , 200 ] (0, 200] (0,200]), and the net worth (integer in [ − 1 0 6 , 1 0 6 ] [−10^6,10^6] [106,106]) of a person. Finally there are K K K lines of queries, each contains three positive integers: M M M ( ≤ 100 \leq 100 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M M M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

Problem Analysis:

由于题目给出的询问要求我们对任意一个给出的年龄段输出最高的满足要求的值,因此我们可以按照年龄将所有人分好组,并排好序,然后每次询问,在由所有组的第一个人构成的序列中选择值最大的那个输出即可。

这里在每组第一个中选择最大值时,可以采用堆来维护,理论时间复杂度是 O ( K M log ⁡ ( 200 ) ) O(KM\log (200)) O(KMlog(200)),但缺点是代码太长,但我们可以退而求其次,以牺牲一小部分速度的代价来换取更加好写、更容易调试的版本,直接遍历求最大值,这样复杂度为 O ( K M ⋅ 200 ) O(KM\cdot 200) O(KM200)

经过较长时间的试错,发现如果用堆维护,那么在每一轮询问中不能让已经入堆的元素重复入堆,那么必然需要哈希来维护所有 Person,而涉及到自定义类型的哈希十分麻烦,需要自定义哈希函数,于是头铁的我直接一顿乱查终于找到了一种能有效避免冲突的哈希方式。但即使解决了哈希的问题,可能是因为常数太大和清空堆的原因,最终依旧有 3 个测试点(AcWing) 和 1 个测试点 (PAT) 超时了。但这里还是记录一下堆的写法。

关于 unordered_map 或者 unordered_<set> key 是自定义类型的问题,可以看 y总的分享

Code

O ( K M ⋅ 200 ) O(KM\cdot 200) O(KM200)
#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>

using namespace std;

const int N = 210;

int n, m;
struct Person
{
    string name;
    int age, w;
    
    bool operator< (const Person& t)const
    {
        if (w != t.w) return w > t.w;
        if (age != t.age) return age < t.age;
        return name < t.name;
    }
};

vector<Person> ages[N];
int idx[N];  // 记录每个序列当前用到第几个数
// 开大小为 N 的存放vector<Person> 的数组
// 跟 vector<vector<Person>> ages 的区别就是第一维不能扩展

int main()
{
    scanf("%d%d", &n, &m);
    
    char name[10];
    for (int i = 0; i < n; i ++ )
    {
        int age, w;
        scanf("%s%d%d", name, &age, &w);
        ages[age].push_back({name, age, w});
    }
    
    for (auto& age : ages) sort(age.begin(), age.end());
	/*
		如果不支持 C++ 14 那么写法就是:
		for (int age = 1; age <= 200; age ++ ) 
			sort(ages[age].begin(), ages[age].end());
	*/
    
    for (int C = 1; C <= m; C ++ )
    {
        printf("Case #%d:\n", C);
        int cnt, a, b;
        scanf("%d%d%d", &cnt, &a, &b);
        
        memset(idx, 0, sizeof idx);
        bool exists = false;
        while (cnt -- )
        {
            int t = -1;  // 当前值最大的序列
            for (int i = a; i <= b; i ++ )
                if (idx[i] < ages[i].size())  // 序列没有用完
                {
                    if (t == -1 || ages[i][idx[i]] < ages[t][idx[t]])
                        t = i;
                }
            if (t == -1) break;  // 所有序列全部选完了
            auto& p = ages[t][idx[t]];
            idx[t] ++ ;
            
            printf("%s %d %d\n", p.name.c_str(), p.age, p.w);
            exists = true;
        }
        if (!exists) puts("None");
    }
                                                                                           
    return 0;
}
O ( K M ⋅ log ⁡ ( 200 ) ) O(KM\cdot \log(200)) O(KMlog(200))
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <unordered_set>

#define x first
#define y second

using namespace std;

const int N =  210;

int n, m;
class Person
{
public:
    string name;
    int age, w;
    
    bool operator< (const Person& t) const
    {
        if (w != t.w) return w > t.w;
        if (age != t.age) return age < t.age;
        return name < t.name;
    }
    
    bool operator== (const Person& t) const  // 重载==号
    {
        return name == t.name && age == t.age && w == t.w;
    }
};

namespace std  // 自定义哈希函数
{
    template <>
    struct hash<Person>
    {
        size_t operator()(const Person& t) const
        {
            int b = 378551;
            int a = 63689;
            int x = 0;
            for (int i = 0; i < t.name.size(); i ++ )
            {
                x = x * a + t.name[i] + t.w;
                a = a * b + t.age;
            }
            return (x & 0x7FFFFFFF);
        }
    };
}

vector<Person> ages[N];
int idx[N];

typedef pair<Person, int> PPI;

int main()
{
    cin >> n >> m;
    char name[10];
    for (int i = 0; i < n; i ++ )
    {
        int age, w;
        scanf("%s%d%d", name, &age, &w);
        ages[age].push_back({name, age, w});
    }
    
    for (auto& age : ages) sort(age.begin(), age.end());
    
    priority_queue<PPI, vector<PPI>, greater<PPI>> heap;
    unordered_set<Person> st;
    
    for (int C = 1; C <= m; C ++ )
    {
        while (!heap.empty()) heap.pop();
        st.clear();
        printf("Case #%d:\n", C);
        int cnt, a, b;
        scanf("%d%d%d", &cnt, &a, &b);
        
        memset(idx, 0, sizeof idx);
        bool exists = false;
        while (cnt -- )
        {
            for (int i = a; i <= b; i ++ ) 
                if (idx[i] < ages[i].size() && !st.count(ages[i][idx[i]]))
                {
                    heap.push({ages[i][idx[i]], i});
                    st.insert(ages[i][idx[i]]);
                }
        
            if (heap.empty()) break;
            
            auto p = heap.top();
            heap.pop();
            idx[p.y] ++ ;
            
            printf("%s %d %d\n", p.x.name.c_str(), p.x.age, p.x.w);
            exists = true;
        }
        if (!exists) puts("None");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值