#1147. Heaps【完全二叉树 + 堆】

原题链接

Problem Description:

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M M M ( ≤ 100 \leq 100 100), the number of trees to be tested; and N N N ( 1 < N ≤ 1 , 000 1 < N \leq 1,000 1<N1,000), the number of keys in each tree, respectively. Then M M M lines follow, each contains N N N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

Problem Analysis:

由于所有的完全二叉树都是按照层序遍历给出,因此我们只需要依次遍历每一个完全二叉树的层序数组,并对其是否是大根堆 / 小根堆做出判断即可:

int check(int w[])
{
    bool flag = true;
    for (int i = 1; i <= n; i ++ )
        if ((i << 1) <= n && w[i << 1] > w[i]) 
        {
            flag = false;
            break;
        }
        else if ((i << 1 | 1) <= n && w[i << 1 | 1] > w[i])
        {
            flag = false;
            break;
        }
    
    if (flag) return 1;
    flag = true;
    for (int i = 1; i <= n; i ++ )
        if ((i << 1) <= n && w[i << 1] < w[i]) 
        {
            flag = false;
            break;
        }
        else if ((i << 1 | 1) <= n && w[i << 1 | 1] < w[i])
        {
            flag = false;
            break;
        }
    
    if (flag) return -1;
    return 0;
}

在读入层序遍历的时候,进行建树,最后从根节点进行深搜,输出其后序遍历。

Code

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>

using namespace std;

const int N = 1e4 + 10;

int n, m;
int w[N];
int h[N], e[N], ne[N], idx;
int ans[N], cnt;

void add(int a, int b)
{
    e[idx] = b, ne[idx] = h[a], h[a] = idx ++ ;
}

void dfs(int u) // 后序遍历
{
    if ((u << 1) <= n) dfs(u << 1);
    if ((u << 1 | 1) <= n) dfs(u << 1 | 1);
    ans[cnt ++ ] = w[u];
}

int check(int w[]) // 判断小根 / 大根 / 非堆
{
    bool flag = true;
    for (int i = 1; i <= n; i ++ )
        if ((i << 1) <= n && w[i << 1] > w[i]) 
        {
            flag = false;
            break;
        }
        else if ((i << 1 | 1) <= n && w[i << 1 | 1] > w[i])
        {
            flag = false;
            break;
        }
    
    if (flag) return 1;
    flag = true;
    for (int i = 1; i <= n; i ++ )
        if ((i << 1) <= n && w[i << 1] < w[i]) 
        {
            flag = false;
            break;
        }
        else if ((i << 1 | 1) <= n && w[i << 1 | 1] < w[i])
        {
            flag = false;
            break;
        }
    
    if (flag) return -1;
    return 0;
}

int main()
{   
    cin >> m >> n;
    
    while (m -- )
    {
        memset(w, 0, sizeof w);
        memset(ans, 0, sizeof ans), cnt = 0;
        memset(h, -1, sizeof h), idx = 0;
        
        for (int i = 1; i <= n; i ++ ) 
        {
            scanf("%d", &w[i]);
            if ((i << 1) <= n) add(i, (i << 1));
            if ((i << 1 | 1) <= n) add(i, (i << 1 | 1));
        }
            
        if (check(w) == 1) puts("Max Heap");
        else if (check(w) == -1) puts("Min Heap");
        else puts("Not Heap");

        dfs(1);

        for (int i = 0; i < cnt; i ++ ) 
        {
            printf("%d", ans[i]);
            if (i != cnt - 1) printf(" ");
        }
        puts("");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值