数据结构基础+STL--符号匹配


You are given astring consisting of parentheses () and []. A string of this type is said to be correct:

(a)

if it is the empty string

(b)

if A and B are correct, AB is correct,

(c)

if A is correct, (A) and [A] iscorrect.

Write a programthat takes a sequence of strings of this type and check their correctness. Yourprogram can assume that the maximum string length is 128.

Input 

The file contains a positive integer n and a sequenceof n strings of parentheses () and [], one string a line.

Output 

A sequence of Yes or No on the output file.

Sample Input 

3

([])

(([()])))

([()[]()])()

Sample Output 

Yes

No

Yes

 

#include<iostream>

#include<stack>

#include<cstring>

#include<cstdio>

using namespace std;

 

bool judge(char a,char b)

{

   if(a=='['&&b==']')return 1;

   if(a=='('&&b==')')return 1;

   return 0;

}

 

bool left(char a)

{

   if(a=='['||a=='(')return 1;

   return 0;

}

 

int main()

{

   int cas;

   char s[200];

   cin>>cas;

   getchar();

   while(cas--)

    {

       stack<char>q;

       gets(s);

       if(strcmp(s,"\n")==0)

       {

           cout<<"Yes"<<endl;

           continue;

       }

       for(int i=0;s[i];i++)

       {

           if(q.empty())

           {

                q.push(s[i]);

           }

           else if(!judge(q.top(),s[i]))

           {

                if(left(s[i]))

                q.push(s[i]);

           }

           else q.pop();

       }

       if(q.empty())cout<<"Yes"<<endl;

       else cout<<"No"<<endl;

    }

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值