数据结构基础+STL--字典翻译

Description

You have justmoved from Waterloo to a big city. The people here speak an incomprehensibledialect of a foreign language. Fortunately, you have a dictionary to help youunderstand them.

Input

Input consistsof up to 100,000 dictionary entries, followed by a blank line, followed by amessage of up to 100,000 words. Each dictionary entry is a line containing anEnglish word, followed by a space and a foreign language word. No foreign wordappears more than once in the dictionary. The message is a sequence of words inthe foreign language, one word on each line. Each word in the input is asequence of at most 10 lowercase letters.

Output

Output is themessage translated to English, one word per line. Foreign words not in thedictionary should be translated as "eh".

Sample Input

dog ogday

cat atcay

pig igpay

froot ootfray

loops oopslay

 

atcay

ittenkay

oopslay

Sample Output

cat

eh

loops

利用map(哈希)完成字典信息的映射。

#include<map>//哈希头文件

#include<iostream>

#include<string>

using namespace std;

int main()

{

         map<string,string>m;//定义map

         chara[20],b[20];

         charstr[40];

         charstr1[20];

          m.clear();//清空

         while(gets(str)&&strlen(str)!=0)

         {

         sscanf(str,"%s%s",a,b);

         m[b]=a;

         }

         while(gets(str1))

         {

                   sscanf(str1,"%s",a);

                   if(m[a]!=" ")

                            cout<<m[a]<<endl;

                   else

                            cout<<"eh"<<endl;

        

         }

         return0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值