hdu 1022 Train Problem I

   HDU                Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47175    Accepted Submission(s): 17708

 

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

 

 Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input. 

 Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output. 

 Sample Input

3 123 321
3 123 312

 Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

 

hint: 

For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.". 

Author    Ignatius.L    Recommend

 先看本人在好友帮助下, 晚上改好AC的代码,然后咱就勉强说这也是一道水题吧?

思路 : 很简单, 比较两个串串, 看看相同就把记录in/out 的 v[] 数组 +1  -1, 表示火车进站了又出站;

i++,j++,继续看下一组;

不相同则串串一 的进站, v[k++] = 1; 如果 栈内有了元素并且栈顶元素与串串二的当前元素相同, 那就走吧, 叮~~~~~~~

如果没了这些情况, 那就是火车站卡了。。。 

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <string.h>
#include <stack>
using  namespace std;

int main()
{
     ios::sync_with_stdio(0);  // 加速一下吧 注意解绑之后下面不能混用scanf了 不然又gg了
     char st1[20], st2[20];
     int n, f, i,j,k;
     bool v[20];               // doushuo 布尔型存的快
     while(cin >> n)
     {
        cin >> st1 >> st2;
        stack <char> s;
        memset(v,0,sizeof(v));      // 清零 试试去掉
        f = 0;i = 0; j = 0; k  = 0;
        while(j < n)
        {
            if(st1[i] == st2[j])
                {
                    i++;
                    j++;
                    v[k++] = 1;
                    v[k++] = 0;
                }
            else if(!s.empty() && s.top() == st2[j])
            {
                s.pop();
                j++;
                v[k++] = 0;
            }
            else if(i < n)
            {
                v[k++] = 1;
                s.push(st1[i++]);
            }
            else
            {
                f = 1;
                break;
            }
         }
         if(f)
         {
             printf("No.\nFINISH\n");
         }
         else
         {
             printf("Yes.\n");
             for(i =0; i < k; i++)
             {
                 if(v[i] == 1)
                    printf("in\n");
                 else
                    printf("out\n");
             }
             printf("FINISH\n");
         }
     }
    return 0;
}

来看看本人花了二十来分钟写了超级错代码, 显然样例正确误导了我

一定要记得不能先压栈, 再比较哪怕你并不是一次性全压栈

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <string.h>
#include <stack>
using  namespace std;
int main()
{
     char st1[20], st2[20];
     int n, v[20];
     while(~scanf("%d",&n))
     {
        int flag = 1;
        stack <char> s; // 因为是多组输入嘛, 所以每次定义一个新的栈吧, 别定义在全局了
        cin >> st1 >> st2;
        memset(v,0,sizeof(v));
        int i = 0, j = 0, k  = 0;
        while(i < n && j < n)
        {
            if(st1[i] == st2[j])
                {
                    i++;
                    j++;
                    v[k++] = 1;
                    v[k++] = 0;
                }
            else
            {
                s.push(st1[i++]);
                v[k++] = 1;
            }
         }
         while(!s.empty())      // 每部分都对, 就是把这个放在了while外面 QAQ
         {
             if(st2[j] == s.top())
             {
                 s.pop();
                 j++;
                 v[k++] = 0;
             }
             else
             {
                 flag = 0;
                 break;
             }
         }
         if(flag == 0)
         {
             printf("No.\nFINISH\n");
         }
         else
         {
             printf("Yes.\n");
             for(i =0; i < k; i++)
             {
                 if(v[i] == 1)
                    printf("in\n");
                 else
                    printf("out\n");
             }
             printf("FINISH\n");
         }
     }
    return 0;
}

再见了, 水提,水提 !!!

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值