搜索算法4之1004

1 题目编号:1004

2 题目内容:

Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.<br>We all like toxophily.<br><br>Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?<br><br>Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m. <br>
 

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.<br>Technical Specification<br><br>1. T ≤ 100.<br>2. 0 ≤ x, y, v ≤ 10000. <br>
 

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.<br>Output "-1", if there's no possible answer.<br><br>Please use radian as unit. <br>
 

Sample Input
  
  
3<br>0.222018 23.901887 121.909183<br>39.096669 110.210922 20.270030<br>138.355025 2028.716904 25.079551<br>
 

Sample Output
  
  
1.561582<br>-1<br>-1<br>
 

Source
The 4th Baidu Cup final

3 解题思路形成过程:给出一个向上速度V,求出最小的角度使得射出的箭能够到达给定的点(x,y)。如果不能输出为-1,如果能到达,输出最小的角度。直接假设能够击中目标,写出公式,化成一元二次方程,根据求根公式求出根。需要注意讨论:x==0&&y==0时,β=0;x==0&&y>0时,β=90;方程无解时,β=-1;方程解为负数时,β=-1。

4 感想:此题与1002类似,也可以采用三分搜索法进行搜索,不过个人感觉直接用方程求解更好更快程序更简单。

5 代码:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main()
{
int t;
double a, b, c;
double x, y, v, tep;
cin >> t;
while (t--)
{
cin >> x >> y >> v;
if (x == 0 && y == 0)
cout << "0" << endl;
else if (x == 0 && y > 0)
cout << "90" << endl;
else
{
a = 9.8 * x * x / (2 * v * v);
b = -x;
c = y + a;
tep = b * b - 4 * a * c;
double jiao;
if (tep < 0)
cout << "-1" << endl;
else
{
double x1 = (-b + sqrt(tep)) / (2 * a);
double x2 = (-b - sqrt(tep)) / (2 * a);


if (x1 >= 0)
jiao = atan(x1);
if (x2 >= 0)
jiao = atan(x2);


printf("%.6f\n", jiao);


if (x1 < 0 && x2 < 0)
cout << "-1" << endl;
}
}
}
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值